
 

Hours Per Week: 6 (4T+2P) Credits: 5 

Exam Hours: 1 ½ Marks: 50U+35P+15I 

Objective: To understand the basic concepts and terminology of informationtechnology and to identify issues 

related to informationsecurity. 

UNIT-I: INTRODUCTION TO COMPUTERS: 

Introduction,Definition,Characteristicsofcomputer,EvolutionofComputer,BlockDiagramOf a computer, 

Generations of Computer, Classification Of Computers, Applications of Computer, Capabilities and 

limitations ofcomputer. 

Role of I/O devices in a computer system.Input Units: Keyboard, Terminals and its types. Pointing 

Devices, Scanners and its types, Voice Recognition Systems, Vision Input System, Touch Screen, Output 

Units: Monitors and its types. Printers: Impact Printers and its types. Non-Impact Printers and its types, 

Plotters, types of plotters, Sound cards,Speakers. 

UNIT -II: COMPUTER ARITHMETIC & STORAGE FUNDAMENTALS: 
Binary,Binary Arithmetic, Number System: Positional & Non Positional, Binary,Octal, Decimal, 

Hexadecimal, Converting from one number system to another. 

Primary Vs Secondary Storage, Data storage & retrieval methods.Primary Storage: RAM ROM, PROM, 
EPROM, EEPROM. Secondary Storage: Magnetic Tapes, Magnetic Disks. Cartridge tape, hard disks, 

Floppy disks Optical Disks, Compact Disks, Zip Drive, Flash Drives. 

 

UNIT-III: SOFTWARE: 

Software and its needs, Types of S/W. System Software: Operating System, Utility Programs 

Programming Language: Machine Language, Assembly Language, High Level Language their advantages 

& disadvantages. Application S/W and its types: Word Processing, Spread Sheets Presentation, Graphics, 

DBMS s/w. 

 

UNIT-IV: OPERATING SYSTEM: 
Functions, Measuring System Performance, Assemblers, Compilers and Interpreters. 
Batch Processing, Multiprogramming, Multi Tasking, Multiprocessing, Time Sharing, DOS, Windows, 

Unix/Linux. 

 

UNIT-V: DATA COMMUNICATION: 
Data, Communication, Basic Networking Devices, Communication Process, Data Transmission speed, 

Communication Types(modes), Data Transmission Medias, Modem and its working, characteristics, 

Typesof Networks, LAN Topologies, Computer Protocols, Concepts relating to networking. 
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Introduction to Computers: 

 

Meaning of a Computer: 

Computer is a machine that can solve problems by accepting data performing certain operations and 

presenting the results of those operations under the direction of detailed step- by-step instructions. Such 

a set of sequenced instructions, which cause a computer to perform particular operations, is called a 

program. The term computer has been derived from the word ―COMPUTE‖ which means calculate. 

Definition of a computer: 

Computer is an electronic device, used for performing calculations and controlling operations that be 

either expressed in logical or numerical terms. 

 It stores and process data in binary form according to instructions given to it in a variable 

program. 

 Computer need to be told exactly what to do and how to do to accomplish a task 

 It is a combination of hardware and software 

 Software is the set of instructions given to the computer to perform a task 

 The physical parts that make up computer are called hardware, which are made of circuits 

and transistors 

The three main operations of computer are 

1) Takes in data and instructions (input) 

2) works with the data (processing) 

3) puts out information (output) 



Characteristics of a Computer: 

The following are the main characteristics of a computer- 

1. Speed: Computer is able to process the data and give the output in fractions of seconds 

such that required information is available to the user on time and hence enables him to take 

right decisions at the right time. 

2. Accuracy: Computer is error free. There is no scope for inaccuracy in the results given 

by the computer. Incorrect calculations, errors, mistake do not take place in a computer 

system. If there errors they are due to the errors in the instructions given by the programmer, 

inaccurate data, inconsistent data or defective programs as well as defective system designs. Since the 

computer is capable of doing only what it is instructed to do, fault instructions for data processing may 

lead to faulty results this is known as GIGO (Garbage In Garbage Out) 

3. Reliable: Today, computer is extensively used because of their reliability. The output 

generated by the computer is very reliable to the extent that the input is reliable. 

4. Storage capacity: Another important characteristic of a computer is that it has brain of its 

own with brilliant memory. It can accept and store any information for a long time. It stores 

large amount of data and can recall information instantly. The main memory of the computer 

is relatively small and holds certain amount of information. Therefore the data is stored in 

secondary memory 

5. Versatile: The computer performs three basic operations. It accepts information from the 

user; secondly it performs the basic arithmetic operations and logical operations and finally 

generates the desired output in the desired form. 

6. Automatic (Programmable): Computer is a device, which is more than a calculator. Once 

instructions are given to the system it works automatically without any human intervention 

until the completion of program until it meets logical instruction to terminate the job. 

7. Diligent: A computer is a device, which is indefatigable (untiring) and therefore does not feel 

tired nor gets distracted like a human being. All the instructions are performed at same speed 

and accuracy 

8. Recreation: In recent years, computers were used mainly for entertainment and amusement, 

like computer games and other programs, computer animation gives life and movement to 

inanimate objects. Multimedia too helped in popularizing the use of computers. 

9. Networking capacity: A computer can be connected with other computers. This feature of 

connectivity with other computers leads to the evolution of computer networking. 

10. Compactness: Now-a-day‘s size of computers has decreased o lot due to increased 

technology. The laptop and Notebook computers can be taken outside. 



Limitations of A Computer: 

Like any modern technology computers is also not free from limitations- 

 Computer is a machine and therefore it is only a device that needs human skill to operate. 

 It does not work on its own and needs set of instructions to be given. 

 It does not have natural intelligence and hence has to be instructed about every step in 

detail. 

 It is not a decision maker and has to be programmed to take an action if some conditions 

prevail. 

 Finally it does not learn by experience unlike intelligent human beings. 

 
Elements of a Computer: 

A computer consists of three basic elements/components such as hardware, software and 

memory. 

Hardware: 

 The physical devices that make up a computer are referred to as hardware. 

 It includes the tangible aspects of computers and can be touched such as mouse, printers, 

monitor, microphone, scanner etc. 

 Hardware is usually used for input and output purposes. It takes instructions from the user 

from input devices such as mouse, key board etc and displays the output (after processing) on 

the other hardware devices such as monitor, LCDs, scanner, printers etc. 

 

Software: 

 The software of the computer includes operating system which executes all the programs 

and instructions given by the user. 

 The computer software itself is categorized into two 



 
 

1. System Software 

 It is collection of programs designed to operate, control, and extend the processing capabilities 

of the computer itself. System software are generally prepared by computer manufactures. 

These software products comprise of programs written in low-level languages which interact 

with the hardware at a very basic level. System software serves as the interface between 

hardware and the end users. 

   Includes the software execution by the computer itself such as Windows and DOS. 

 
2. Application Software 

 Application software products are designed to satisfy a particular need of a particular 

environment. 

 Application software may consist of a single program, such as a Microsoft's notepad for writing 

and editing simple text. It may also consist of a collection of programs, often called a 

software package, which work together to accomplish a task, such as a spreadsheet package. 

 

Memory: 

 The memory of the computer can also be categorized under hardware but sometimes it is 

considered as a separate element of the computer system. 

 Memory allows the user to store the data and processes performed by the computer. 

 Memory is divided mainly into RAM, ROM and secondary storage devices. 

 All these components are essential for the effective functioning of computer system 

Central Processing Unit (CPU). 

 

FUNCTIONAL BLOCK DIAGRAM OF COMPUTER: 
 

• A Computer, like a human brain, receives data and instruction, stores them and processes the 

data according to the instructions given to it. 

• It receives data from input devices, stores them in memory and displays them through on an output 

device 



 
 

 

 

Central Processing Unit (CPU) 

CPU is the component of computer system with the circuitry to control interpretation and execution of 

instructions. It performs the process in parts of Input-Process-Output cycle. The components of CPU are 

mounted (Fixed) on the main circuit board, called the ―motherboard‖. 

The various components of a Central Processing Unit are: 

1. Arithmetic Logic Unit (ALU). 

2. Control Unit. 

 

Arithmetic and Logic Unit (ALU) 

 It is that part of CPU where actual data processing occurs. 

 All mathematical operations (+, -, *, /) and all comparisons (>, <, =) take place in this unit. 

 In addition to arithmetic functions, the ALU also performs logic functions. 

 A logic function is one where numbers or conditions are compared to each other. 

 Circuits in the ALU are generally used to compare two numbers by subtracting one from 

the other. 

 The sign (negative or positive) and the value of the difference tell the processor that the 

first number is equal to, less than, or greater than the second number. 

 Alphabetic data may also be compared according to an assigned order sequence. 

 

Control Unit 

 It is a component of CPU that control and coordinates the flow of data between different 

components of computer. 



 It interprets instructions it receives from memory and directs the sequence of events 

necessary to execute the instruction. 

 Control Unit uses a system clock, which synchronizes (manage) all tasks by sending out 

electrical pulses. 

 Clock speed (the number of pulses or clocks per second) is measured in Megahertz (MHz) 

and is the main element in determining the speed of the processor. 

 Computer speed is also measured in the number of instructions completed per second, or 

Millions of instructions per second (MIPS). 

 

MEMORY 

The memory is that part of the computer where programs and data are stored. There are two 

types of memory: 

1. Primary Memory – MAGNETIC DISK 

2. Secondary Memory – MAGNETIC TAPES, OPTICAL DISK 

 
1. PRIMARY MEMORY (MAIN MEMORY): 

Primary memory holds only those data and instructions on which computer is currently 

working. It has limited capacity and data is lost when power is switched off. It is generally 

made up of semiconductor device. These memories are not as fast as registers. The data and 

instruction required to be processed reside in main memory. 

Primary storage or main memory stores three types of information for very brief periods 

of time: 

 Data to be processed by the CPU. 
 Instructions for the CPU as to how to process the data. 

 Operating system programs that manage various aspects of the computer‘s operation. 

There are four main types of primary storage 

1. Random access memory (RAM) 

2. Read-only memory (ROM). 

3. Cache memory and 

4. Register 

 
1. Random Access Memory(RAM): 

This is that part of primary storage where data and program instructions are held 

temporarily while being manipulated and executed. It is called Random Access Memory because 

any of the locations on a chip can be randomly selected and used to directly store and retrieve 

data and instructions. RAM is volatile i.e. it is depends on a steady supply of electricity and when 

the power is shut off, everything stored is lost. 

Access time in RAM is independent of the address i.e., each storage location inside the 

memory is as easy to reach as other locations and takes the same amount of time. Data in the 

RAM can be accessed randomly but it is very expensive. 



RAM chip may be classified as: 

 Static RAM chip: It also provides volatile storage, but as long as it is supplied with 

power, it needs no special regenerator circuits to retain the stored data. Static RAM 

chips are more complicated and take up more space than dynamic RAM chips. 

Therefore, static RAMs are used in specialized applications while dynamic RAMs 

are used in primary storage section. 

Other types of RAM are: 

 SDRAM (Synchronous Dynamic RAM) 

 DDR (Double Data Rate SDRAM) 

 Rambus DRAM (RDRAM) 

 Dynamic RAM chip (DRAM): DRAM, unlike SRAM, must be continually 

refreshed in order to maintain the data. This is done by placing the memory on a 

refresh circuit that rewrites the data several hundred times per second. DRAM is 

used for most system memory because it is cheap and small. 

Access time 60 – 70 nanoseconds. 

Note: A nanosecond is one billionth of a second! A Dynamic RAM chip provides 

volatile storage. 

 
2. Read Only Memory (ROM): 

Read only memory chip contains the stored data when the supply is cut. So, unlike RAM 

chips, ROM chips are non-volatile. ROM chip may contain micro program control 

instructions that cause the machine to perform certain information such as starting the computer 

or instructions to the Operating System. ROM chip can only read. It doesn‘t accept any input 

data on instructions from user. The actual contents are set by the manufacturers and they are 

unchanged and permanent. ROM chips are not only used in the computer but also in other 

electronic items like washing machine and microwave oven. ROM is mainly of three types: 

1. Programmable read only memory (PROM) allows a chip to be programmed by the user for 

converting critical and lengthy operations into micro programs that are fused into a chip. The 

user buys a blank PROM and enters the desired contents using a PROM program. Inside the 

PROM chip there are small fuses which are burnt open during programming. It can be 

programmed only once and is not erasable. Once they are in a hardware form, they can be 

executed at a very high speed and can‘t be altered. 

2. Erasable PROM (EPROM) can be erased and reprogrammed. The EPROM chip has a small 

window on top allowing it to be erased by exposing it to ultra-violet light for duration of up to 

40 minutes. After reprogramming the window is covered to prevent new contents being 

erased 

3. Electrically Erasable PROM (EEPROM) is programmed and erased electrically. It can be 

erased and reprogrammed about ten thousand times. Both erasing and programming take 

about 4 to 10 ms (milli second). In EEPROM, any location can be selectively erased and 

programmed. EEPROMs can be erased one byte at a time, rather than erasing the entire chip. 

Hence, the process of re-programming is flexible but slow. 



3. Cache Memory: 

Cache memory is typically integrated directly with the CPU chip or placed on a separate chip. 

Many processors also have built-in specialized storage elements that are used for specific 

processing and control purposes. A computer microprocessor can access more quickly than it can 

access regular RAM. 

The basic purpose of cache memory is to store program instructions that are 

frequently re-referenced by software during operation. Fast access to these instructions 

increases the overall speed of the software program. 

One element used during processing operations is a high speed Buffer Memory 

(cache memory), which is both fast and expensive, as compared to primary storage. It is a 

small amount of memory typically of 256 or 512 kilobytes. 

L1 and L2 are levels of cache memory in a computer. L1 is "level-1" cache 

memory, usually built onto the microprocessor chip itself. L2 (that is, level-2) cache 

memory is on a separate chip that can be accessed more quickly than the larger "main" 

memory. 

 
4. Registers 

Registers are a special high-speed storage area within the CPU. All data must be represented in a 

register before it can be processed. For example, if two numbers are to be multiplied, both 

numbers must be in registers, and the result is also placed in a register. (The register can contain 

the address of a memory location where data is stored rather than the actual data itself.) 

The number of registers that a CPU has and the size of each (number of bits) help 

determine the power and speed of a CPU. For example a 32-bit CPU is one in which each register 

is 32 bits wide. Therefore, each CPU instruction can manipulate 32 bits of data. 

The CPU contains a number of special-purpose registers 

 Instruction Register (IR): The instruction register holds the instruction currently 

being executed. 

 Memory Data Register (MDR): The memory   data   register (also   known   as the 

memory buffer register or data buffer) holds the piece of data that has been fetched 

from memory. 

 Memory Address Register (MAR): The memory address register holds the address 

of the next piece of memory to be fetched. 



 Program Counter Register (PC): The program counter holds the location of the 

next instruction to be fetched from memory. It is automatically incremented between 

supplying the address of the next instruction and the instruction being executed. 

 Accumulator Register: The accumulator is an internal CPU register used as the 

default location to store any calculations performed by the arithmetic and logic unit. 

 

 

2. SECONDARY MEMORY: 

Secondary (Auxiliary) storage is the non-volatile memory that is stored externally to the 

computer. A secondary medium usually used for the storage of large amount of data for 

permanent or long-term storage of data or programs. While the secondary media can hold 

much more data than primary storage, access to the data is slower. 

The benefits of secondary storage are 

 Capacity: A simple diskette for a personal computer holds the equivalent of 500 printed 

pages, or one book. An optical disk can hold the equivalent of approximately 400 books. 

 Reliability: Data in secondary storage is basically safe, since secondary storage is 

physically reliable. Also, it is more difficult for unscrupulous people to tamper with 

data on disk than data stored on paper in a file cabinet. 

 Convenience: With the help of a computer, authorized people can locate and access data 

quickly. 

Different secondary storage media can be ranked according to the following criteria: 

 Retrieval speed - The access time of a storage device is the time it takes to locate and 

retrieve the stored data. A fast access time is preferable for any storage media. 

 Storage capacity- A device‘s storage capacity is the ability to store data. A large storage 

capacity is desired. 



 Cost per bit of capacity- Low cost is preferred. 

 Secondary storage media with all sizes of computers can be broadly categorized into: 

1. Magnetic tape. 

2. Magnetic disk. 

3. Optical disk. 
 

1. Magnetic tape: 

Magnetic tape is a one-half or one-fourth inch ribbon of Mylar (a plastic like material) coated 

with a thin layer of iron-oxide material. It is a medium that is often selected to store large files 

that are sequentially accessed and processed. Its data density (the number of characters that can 

be stored in a given physical space) is high and its transfer rate (the speed with which data can be 

copied into processor storage) is fast. 

Advantages: 

 Low cost and ease of handling. 

 High data density Limitations of Magnetic Tape: 

 Lack of direct access to records. 

 Environmental problems-sensitivity to dust, humidity and temperature levels. 

 
2. Magnetic disk: 

A magnetic disk is a Mylar or metallic platter on which electronic data are stored. Unlike 

magnetic tapes, data on magnetic disks can also be read randomly. The data are recorded as tiny 

invisible magnetic spots on its iron oxide coating. 

It consists of two or more metal platters mounted on central spindle like a stack. Each platter 

is covered with a magnetic coating, and the entire unit is encased in a sealed chamber. The motor 

spins the platter and sets the read/write head on the disk to read from or to write on to the disk. 

The top most layer of the top platter and bottom most layer of the bottom platter is not used to 

storing a data as they may contain some dust particles. These heads are fastened to an arm in a 

disk storage device so that they can be moved quickly and directly to any disk location to store or 

retrieve data. 

The surface of the magnetic disk is divided into number of invisible concentric circles called 

―tracks‖. The tracks are further subdivided into ―sectors‖, ―blocks‖ etc. each its own unique 

addresses to facilitate the location of data. Disk moves on a vertical rotating spindle. Data on 

magnetic disks can be read randomly. 

The access time for data stored on a magnetic disk is determined by two factors: 

1. The seek time i.e. the time required for positioning read/write head over the proper track. 

2. The search time i.e. the time required for spinning the required data under the head. 

Magnetic disks come in various sizes. They can be portable or permanently mounted in 

their storage devices, disk drives. They can be made of rigid metal (Hard Disks) or flexible 

plastic (Floppy Diskettes). 

Advantages of Magnetic Disk 

 Data records can be stored for both sequential and direct-accessing. 



 High speed of access and update as no sorting of transactions. 

 On-line disk records of several related files can be updated simultaneously by a 

single input transaction. 

Limitations of Magnetic Disk 

1. Risk of loss of data – Records may be lost in case of writing of new records or drive 

failure. Therefore, special backup procedures are required for disk records protection. 

This is not so in the case of magnetic tape records. 

2. Data insecurity – It is easier to maintain the security of magnetic tape files than that 

of magnetic disk files. 

3. Optical Technology: 

Optical technology involves the use of laser beams highly concentrated beams 

of light. It comes in the form of Optical laser disk, Optical card and Optical tape. 

 
Optical Laser Disk: A common version of the optical disk is the CD-ROM (compact disk, read–only 

memory). While not suited to applications where data changes, they are very convenient for storing data 

that remains constant. 

CD-ROM [Compact Disc Read Only Memory] is a Compact Disc contains data accessible by a computer. 

 The CD-ROM is also known as a laser disc, which is shiny metal like disk. The diameter of the 

disk is 5.25 inches (or) 12 cm disk. Information of 650 MB can be stored, which is equal to 

nearly 2, 50,000 pages of printed text. 

 The data is recorded as deep holes on the disk surface or burning microscopic bits. 

 CD-ROMs are popularly used to distribute computer software, including games and 

multimedia applications, though any data can be stored. 

 The CD-ROM s are pre-recorded disks used for storing a large amount of data (or) 

information. 

Optical Card: The Optical card, or laser card, is the size of a credit card and has an optical laser- 

encoded strip that can store approximately 2 megabytes of data. These cards have many potential uses, 

most notably for storing credit records or medical histories. 

 

Optical Tape: Optical tape is similar in appearance to magnetic tape, but data are stored by optical laser 

techniques. Optical tapes, which are in cassette form, can store over 8 gigabytes each providing a total 

storage of about 1 terabyte (1,000 gigabytes). Like other optical methods of data storage, optical tape 

is read only. 



 
 

INPUT AND OUTPUT DEVICES: 

The CPU provides the means for the fast and efficient processing of data into usable information. For 

computer processing, data needs to be entered into the computer (input) and the result of processing 

needs to be communicated to the user (output). 

Any hardware item which is attached to the main unit of a computer that houses the CPU is referred to 

as a Peripheral Device. 

 INPUT: Input is the process of entering and translating incoming data in machine- readable 

form. The data to be entered are often referred as input. Input process involves data 

preparation, processing and accuracy checks. 

There are two types of input device: manual and automatic. 

 A Manual Input Device requires a human hand to control i.e. (Mouse, Keyboard, 

Scanner, Camera, track ball, joystick, and Graphics tablet.) 

 An Automatic Input Device inputs data without the need for human intervention (once 

the device has been set up), e.g. MICR, OMR, barcode reader, webcam, microphone. 

 OUTPUT: The result of processing is also often referred as output. Output is divided into 

two general categories: 

Output that can be readily understood and used by humans. 
Output to secondary storage devices that hold the data to be used as input for further 

processing by computer. 
Output that can be understood by humans can be in the form two types: Hard copy & 
Soft copy. 

 Hard Copy is the output on paper and can be read immediately or stored and read 

later. This is a relatively stable and permanent form of output. 

 Soft Copy is usually a screen-displayed output. It is a transient form of output and 

is lost when the computer is turned off. 



INPUT DEVICES: 

An input device is a peripheral device through which data are entered and transformed into 

machine-readable form. Let us have a look at various input devices available. 

 

1. Keyboards 
Standard keyboard is the most common and familiar input device. A typical computer 

keyboard contains all letters, numbers, symbols of a regular typewriter, plus other keys. 
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Keys Description 

1 Typing Keys 
These keys include the letter keys (A-Z) and digits keys (0-9) 

which generally give same layout as that of typewriters. 

 

2 

 

Numeric Keypad 

It is used to enter numeric data or cursor movement. 

Generally, it consists of a set of 17 keys that are laid out in 

the same configuration used by most adding machine and 

calculators. 

 

3 

 

Function Keys 

The twelve functions keys are present on the keyboard. These 

are arranged in a row along the top of the keyboard. 

Each function key has unique meaning and is used for some 

specific purpose. 

 

4 

 

Control keys 

These keys provide cursor and screen control. It includes four 

directional arrow key. Control keys also include Home, End, 

Insert, Delete, Page Up, Page Down, Control(Ctrl), 

Alternate(Alt), Escape(Esc). 

 
5 

 
Special Purpose 

Keys 

Keyboard also contains some special purpose keys such as 

Enter, Shift, Caps Lock, Num Lock, Space bar, Tab, and Print 

Screen. 

 

 

Every key on the keyboard underneath it consists of a tiny chip called as keyboard controller, when a 

key is pressed the controller places the code into the part of the memory called keyboard buffer. The 

buffer temporarily holds the data till it is processed. The signal the keyboard sends to the computer is 

called as interrupt. The keyboard sends an interrupt request to the system software and the data is 

processed. 



2. Mouse 

A mouse is a pointing device. It usually contains one or three buttons: as the user rolls it on a 

flat surface, the mouse controls cursor movement on the screen. When the user presses one of 

the buttons, the mouse either marks a place on the screen or makes selections from data on 

the screen. It can be used for many applications ranging from games to designing products 

with graphics. It can be used as an alternative to keyboard or it can be used in combination 

with a keyboard to enhance input operations. 

Advantages: 

 Easy to use 

 Not very expensive 

 Moves the cursor faster than the arrow keys of keyboard. 

 
3. Joystick 

A joystick is a most popular input device used to play video games. A joystick uses a level to 

control the position and speed with which the joystick is moved into digital signals that are 

sent to the computer to control the cursor movement. 

4. Track Ball 

A track ball uses a hard sphere to control cursor movement. The ball can be rotated by hand in 

any direction. The track ball translated the sphere‘s direction and speed of rotation into a 

digital signal, used to control the cursor. 
 

 

 
 

5. Touch Screen 

A touch screen registers input when a finger or other object comes in beams and ultrasonic 

acoustic waves. Infrared beams crisscross the surface of the screen and when a light beam is 

broken, that location is recorded. 

6. Light Pen 

A light pen is also a pointing device like mouse. It can be used to choose a displayed menu 

option. The pen contains a photocell placed in a small tube. As the user moves the tip of the 

pen over the surface of the screen, it detects the light coming from a limited field of view. The 

light from the screen causes the photocell to respond and this electric response is transmitted 

to the process, which can identify the menu option that is triggering the 



                         photocell. Light pen is useful for graphics work, especially for Computer Aided Design    

                       (CAD) purposes. 

 

3. Magnetic Ink Character Recognition (MICR) 

Magnetic Ink Character Recognition (MICR) is an interpretation by computer of a line of 

character written in special magnetic ink. These characters can be read by human eye as 

well. There are several advantages associated with the use of MICR: 

 Checks may be roughly handled, folded, smeared, and stamped. But they can still 

be read with a high degree of accuracy. 

 People can easily read the magnetic ink characters. 

The main limitation of MICR is that only the 10 digits and 4 special characters needed 

for bank processing are used. No alphabetic characters are available. 

4. Magnetic strips 
 

They are thin bands of magnetically encoded data that are found at the back of usually, 

Credit cards, Debit cards etc. the data stored on the card vary from application to another. 

Data in the form of magnetic strips cannot be seen or interpreted by simply looking at the 

card and so it can be highly sensitive or personal. 

5. Optical Recognition / Scanners 
 

Optical Recognition when a device scans a printed surface and translates the image the 

scanner sees into a machine-readable format that is understandable by the computer. 

Optical Recognition can be of the following types 

 

 

i. Optical Mark Recognition (OMR) 
 

It uses mark sensing to scan and translate, based on its location, which is a series of pen or 

pencil marks into a computer readable form. For instance, the objective type multiple 

choice question 

paper we get in the bank recruitment exam. A computerized optical mark reader scores the 

tests by identifying the position of the mark 

ii. Optical Bar Recognition (OBR) 

 

This is slightly more sophisticated type of optical recognition. An optical bar reader 

recognizes and interprets bar codes or product codes which are arranged to represent 

data, such as the name of the 



manufacturer, and the type of the product etc. on the basis of the width of the lines. A 

scanner reads the bar code, and the computer then matches the price and product. 
 

iii. Optical character recognition (OCR) 
 

This is most sophisticated type of optical recognition. An optical card reader works in 

much the same way as a human eye. It recognizes specially shaped numerical and 

alphabetic characters. 

6. Microphone 

 

A microphone can be attached to a computer to record sound (usually through a sound 

card input or circuitry built into the motherboard). The sound is digitized—turned into 

numbers that represent the original analog sound waves 

—and stored in the computer for later processing and playback. 

 

OUTPUT DEVICES: 
 

An Output Device is a peripheral device that allows a computer to communicate 

information to humans or another machine by accepting data from the computer and 

transforming them into a usable form. 

 

1. Visual Display Unit (Monitor) 

A monitor is a television like device used to display input data or information, 

allowing users to view the results of processing. The combination of monitor with the 

keyboard is called a terminal. 

Quality of a monitor often judged as in terms of resolution, which is a measure of 

the number of picture elements, or pixels, a screen, contains. A pixel is the smallest 

increment of a display screen that can be controlled individually. The higher the number of 

pixels, the clearer and sharper is the image. Screens for the monitor are of two types: 

1. Cathode Ray Tube (CRT): On this type of screen, a data image can be produced 

by moving an electron beam across a phosphor-coated screen. CRT has display 

screen 25 lines of 80 characters each. It is used in most desktop monitors. Some 

CRT screens are monochrome (1 color) while other produce many color. 

2. Flat Panel Display: To overcome the limitation of CRT like bulky in size, high 

power consumption, flickering screen Flat panel display is used. The most 

common form of flat panel display is the Liquid Crystal Display (LCD), which 

produces images by aligning molecular crystals and an LED display which 

uses an array of light-emitting 



diodes as a video display. An LED panel is a small display, or a component 

of a larger display. 

2. Printer 
Produces output usually in the form of text on a paper. 

Printers are classified based on the contact between the printer head and the paper into 

 Impact printers 

 Non Impact printers 

 

 

Dot Matrix Printer 

It uses printer heads containing a 9-24 pins these pins produced pattern of dots on the 

paper to form a character. 

Dot matrix printers are very popular as they are relatively 

inexpensive and typically print at speed of 100-600 characters per second. These printers 

can give us draft quality, standard quality and near letter quality prints 

 

Daisy Wheel Printer: This printer gives us letter quality print but is slow, typically 25 to 

55 characters per second. It is a circular printing element which has a plastic or metal 

wheel on which the shape of each character stands out in relief. A hammer presses the 

wheel against a ribbon, which in turn makes an ink stain in the shape of the character on 

the paper. Daisy- wheel printers produce letter-quality print but cannot print graphics. 

 

 

 

 

 

 

 

Line Printers: The line printer is a form of high speed impact printer in which one line 

of type is printed at a time. Print speeds of 600 to 1200 lines- per-minute (approximately 

10 to 20 pages per minute. Types of line printers 

• Drum Printer 

• Chain Printer 

 

Typical typeface of a drum printer with staggered characters. 

A fixed font character set is engraved onto the periphery of a number of print wheels. The 

wheels, joined to form a large drum (cylinder), spin at high speed and paper and an 

inked ribbon is stepped (moved) past the print position. As the desired character for 

each column passes the print position, a hammer strikes 



the paper from the rear and presses the paper against the ribbon and the drum, causing the 

desired character to be recorded on the continuous paper. 

 
Non Impact Printers: 
Non-impact printers are much quieter than impact printers as their printing heads do 

not strike the paper. The main types of non-impact printer are: 

– Thermal Printer 

– Laser Printer 

– Ink Jet Printer 

1. Thermal Printer 

Characters are formed by heated elements being placed in contact with special 

heat sensitive paper forming darkened dots when the elements reach a critical 

temperature. 

2. Laser Printer 

When speed and quality are required and cost is no 

factor a laser printer is the solution. They produce images on 

paper by directing a laser beam at a minor, which bounces the 

beam on to a drum. The laser leaves a negative charge on the 

drum to which positively charged black toner powder will 

stick. As the paper rolls by the drum, the toner is transferred 

to the paper. Laser printer uses buffer to store an entire 

page at a time that is why 

they print very fast at rate of approximately 21,000 lines or 437 pages per minute. 

3. Ink-Jet Printer 

Ink-Jet printer forms character on paper by spraying ink from tiny nozzles 

through an electrical field that arranges the charged ink particles into characters at the 

rate of approximately 250 characters per second. The ink is absorbed into the paper 

and dries instantly. 

Various colors of ink can be used. Although 

this might sound like a messy way of printing, ink-jet printers are reliable, but 

expensive stationary piece of paper. High quality bar graphs, pie charts created with a 

plotter give a very good quality product. 

 

4. Sound Card and Speakers 
 

A sound card captures sounds and changes them into digital binary numbers that are 

stored as files in your computer.When outputting sounds the sound card reverses the 

process and changes binary data held in the sound files into analogue signals that are 



used control the speakers attached to the computer. Speakers convert analogue audio 

signals into the equivalent air vibrations in order to make audible sound. A pair of 

speakers plugs into the computer‘s sound card. 

 

5. Projector 

Projector may refer to: 

 Image projector, a device that projects an image on a surface 3D projection, a 

method of mapping three- dimensional points to a two-dimensional plane. 

 Video projector, a device that projects a video signal from computer, home 

theater system etc. 

 Movie projector, a device that projects moving pictures from a filmstrip Slide 

projector. 

Computer Network: 
 

Local-Area Network (LAN): 

A local area network(LAN) is two or more computers directly linked within a small well- 

defined area such as a room, office building, or a campus. A LAN can be made up of only 

microcomputer or any combination of microcomputer and large system. Main benefit of 

LAN is reduction of hardware and software costs because user can share several 

computers, peripheral devices such as laser printers, color printers, hard disk, and 

modems. Another benefit of LAN is the user can share the same data. 

A LAN generally consists of the following. 
 

5.1. Two or more computers. 

5.2. Software to control the operations of the computers. 5.3.Peripheral devices such as 

modems, printers, plotters etc. 5.4.Coaxial or fiber optic cables are usually used to 

connect the 

computers and there devices. 

5.5. A plug-in board to handle the data transmissions. 

 
Some LAN‘s specifically requires all the computers to be of a certain brand while others 

allow a variety of brands to be connected. The number of computers in LAN varies widely 

from small LANs that connect two to twenty five computers, to large LANs that may 

connect more than 10,000 computers. 

LAN must get the data to its destination, transmit the data correctly, and prevent 

unauthorized users from gaining access to that data. 



Metropolitan-Area Networks (MAN): 
A Metropolitan-Area Network (MAN) is a network that is larger than a LAN. It is called 

metropolitan since it normally covers the area of a city. Different hardware and 

transmission media are often used in MAN because they must efficiently cover these 

distances (a few tens to about one hundred kilometers). Wide-Area Networks 

(WAN): 

A Wide-Area Network (WAN) is two or more geographically dispersed computer, linked 

by communication facilities such as telecommunication or microwave relays. In other 

words, one of the most significant aspects of Wide-area network while comparing it with 

the freedom of a local-area network is the involvement of public telecommunication 

authority. WAN is usually limited to use by large organizations and government agencies 

due to high costs involved in building and maintaining them. 

There are two specific categories of WAN, 

 Enterprise: An enterprise network connects all LAN‘S of a single organization. 

The term is normally used for networks connecting extremely large organization, 

or for those that cross regional boundaries. 

 Global: By definition a global network is one that spans the earth. While global 

networks may not cover the entire globe, they cross multiple national boundaries 

and may include the networks of several organizations. 

NETWORK TOPOLOGY: 

Each computer or device in a network is called a node. The geometrical arrangement of 

computer resources, remote device and communication facilities are known as network 

topology. 

A network topology can be made in one of the five different topologies. 

1. Mesh Topology 

2. Bus Topology 

3. Ring Topology 

4. Star Topology 

5. Tree Topology 

6. Hybrid Topology 

 

1. Mesh Topology: 

Mesh Topology has point-to-point connection between every device in the 

network. Each device requires an interface for every other device on the network. Mesh 

topologies are not usually considered practical, in addition unless each station frequently 

sends signals to all the other station, an excessive amount of network bandwidth. 



Advantages : 

 Units affected by media failure:Mesh topologies resist media failure better than 

other topologies. Implementations that include more than two devices will always 

have multiple paths to send signals from one device to another. If one path fails, 

the transmission signals can be routed around the failed link. 

 Easy for troubleshooting: Mesh network are easy to trouble shoot because, each 

medium link is independent of all other devices. 

Disadvantages : 

 Difficult to install: Mesh networks are relatively difficult to install because each 

device must be linked directly to all other devices, as the number of devices 

increases, the 

difficulty of installation increases geometrically. 

 Difficult to reconfigure: Mesh topologies are 

difficult to reconfigure for the same reasons that they are difficult to install. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Bus Topology 
In a Bus Topology, each computer is connected to a single communication cable 

via an interface and every computer can directly communicate with every other computer 

or device in the network. This topology is commonly used along with the local area 

networks. 



Advantages : 

 Short cable length and simple wiring layout: Because there is a single common data path 

connecting to all nodes, the bus topology allows a very short cable length to be used. This 

decreases the installation cost and also leads to a simple, easy to maintain wiring layout. 

 Reliable architecture:The bus architecture has an inherent simplicity that makes it very 

reliable from a hardware point of view. There is a single cablethrough which all data passes 

and to which all nodes are connected. 

 Easy to extend: Additional nodes can be connected to an existing bus network at any point 

along its length. 

 

Disadvantages: 

 Fault diagnosis is difficult:Although the simplicity of the bus topology means that there is 

very little that can go wrong, fault detection is not a simple matter. In most LANs based on a 

bus, control of the network is not centralized in any particular node. This means that 

detection of a fault may be performed from many points in the network. 

 Fault isolation is difficult: If a node is faulty on a bus, it must be rectified at the point where 

the node is connected to the network. 

 Repeater configuration:When a bus network has its backbone extended using repeaters, 

reconfiguration may be necessary, this may involve additional cable lengths and adjusting 

terminators, etc. 

 Nodes must be intelligent:Each node on the network is directly connected to the central bus, 

this mean that some way of deciding who can use the network at any given time must be 

performed in each node. It tends to increase the cost of the nodes. 

 
 

 

3. Ring Topology: 
 

In a Ring Topology, several devices or computers are connected to each other in a closed 

loop by a single communication cable that is why a ring network is also called loop 

network. In the ring network, data must travel around the ring to each station in turn until 

they arrive at the required station. A thing can be unidirectional or bi-directional. In a 

unidirectional ring, data moves in one direction only, and in a bi-directional ring, data 

moves in both directions, but in only one direction at a time. 



Advantages: 

 Short cable length:This means that fewer connections will be needed, which will 

in turn increase network reliability. 

 No wiring closet space required:Since there is only one cable connecting each 

node to its immediate neighbors, it is not necessary to allocate space in the 

building for wiring closets. 

 Suitable for optical fibers:Optical fibers offer the possibility of very high speed 

transmission. Because traffic on a ring travels in one direction, it is easy to use 

optical fibers as a medium of transmission. 

 

Disadvantages: 

 

 Node failure causes network failure:The transmission of data on a ring goes 

through every connected node on the 

ring before returning to the sender. If one node fails to pass data though itself, 

the entire network has failed and no traffic can flow until  the 

defective     node 

has been 

removed from the ring. 

 Difficult    to diagnose faults:The  fact that failure   of one

node will affect all others has  serious implications  for fault 

diagnosis. It may necessary to examine a series of adjacent nodes to determine the 

faulty one. 



 Network reconfiguration is difficult:It is not possible to shut down a small section 

of the ring while keeping the majority of it working normally. 

 Topology affects the access protocol:Each node on a ring has a responsibility to 

pass on data that it receives. This means that the access protocol must take this in 

to account. 

Before a node can transmit its own data, it must ensure that the medium is 

available for use. 

 

4. Star Topology: 
In Star Topology, several devices or computers are connected to one centralized 

computer; the main disadvantage of star network is that none of the other computer can 

communicate with each other if the central computer breaks down. 

Advantages: 

 Ease of service:The star topology has a number of concentration points, these 

provides easy access for service of reconfiguration of 

the network. 

 One device per connection: In star topology, failure of a single connection typically 

involves disconnecting one node from an otherwise fully functional network. 

 Centralized control/problem diagnosis:The fact that the central node is connected 

directly to every other node in the network means that faults are easily detected and 

isolated. 

 Simple    access     protocols: Any     given connection involves only the central node 

and one peripheral node makes the access protocols very simple. 

Disadvantages: 

 Long cable length: Because each node is directly connected to the center, the star 

topology necessitates a large quantity of cable. 

 Difficult to expand: The addition of a new node involves a connection all the way 

to the central node. Problems can arise if a longer cable length is needed or an 

unanticipated concentration of nodes is required. 

 Central node dependency: If the central node in a star network fails, the entire 

network is rendered inoperable. 



5. Tree Topology: 
In a Tree Topology, several devices or computers are linked in a hierarchical 

form. It is also known as hierarchical network. This type of distribution system is 

commonly used in the organization, where head quarters communicate with regional 

offices and regional offices communicates with district offices and so on. 

Advantages: 

 Easy to extend:Because the tree is, of its very nature, divided into sub units, it is easier 

to add new nodes or branches to it. 

 Fault isolation:It is possible to disconnect whole branches of the network from the 

main structure. This makes it easier to isolate a defective node. 
 

 

Disadvantages : 

 Dependent on the root: if the ―head end‖ device fails to operate, the entire network 

is in operative. 



UNIT –II SOFTWARE & NETWORKS 

Software: Definition Of Software-System Software-Application Software, Computer 
Languages: Machine, Assembly & High Level Languages. Operating System, Functions of 
Operating System, Types of Operating System. 
Networks: Definition- Network Types: LAN, MAN, WAN –Network Topologies: BUS, STAR, 
and RING. 
Modern communications: FAX, Voice Mail, E-Mail, Tele-Conferencing, Video-conferencing 

Software 
Software is organized collection of computer data and instructions. It is responsible for 

controlling, integrating, and managing the hardware components of a computer to accomplish 
specific task 

Software tells the computer what to do and how to do. Thus, software communicates 
with the hardware by organizing the control sequences, and the hardware carries out the 
instructions defined by software 
Software is divided into two parts 

1. System software 
2. Application software 

 
System Software 

 It helps in running the computer hardware and the computer system. System software 

is a collection of operating systems; device drivers, servers, and system utilities. 

 System software is used by the computer to translate inputs from various sources into 

a language which a machine can understand. Basically, the OS coordinates the different 

hardware components of a computer i.e., System software is the communicator of user 

and hardware. 

 System software provides the platform for users to install and run application 

software, and it's made up of multiple programs needed to run a computer system 

smoothly 

Application software 

 Application software consists of standalone programs that solve a specific business 

need. 

 Any application program is dependent on a computer's system software to deliver 

specific functionality to a user. 

 There are several minor application programs, called utilities programs that are 

integrated into an operating system to manage the computer's hardware resources, 

such as the hard drive, memory modules, graphics and audio cards. 



GENERATIONS OF COMPUTER LANGUAGES 

Just as humans use language to communicate, and different regions have different 

languages, computers also have their own languages that are specific to them. 

Different kinds of languages have been developed to perform different types of work on 

the computer. Basically, languages can be divided into two categories according to how the 

computer understands them. 

Two Basic Types of Computer Language 

Low-Level Languages: A language that corresponds directly to a specific machine 

High-Level Languages: Any language that is independent of the machine 

These languages are not mutually exclusive, and some languages can belong to multiple 

categories. The terms low-level and high-level are also open to interpretation, and some 

languages that were once considered high-level are now considered low-level as languages 

have continued to develop. 

Low-level computer languages are either machine codes or are very close to them. A 

computer cannot understand instructions given to it in high-level languages or in English. It 

can only understand and execute instructions given in the form of machine language i.e. 

binary. There are two types of low-level languages: 

 
 Machine Language: a language that is directly interpreted into the hardware 

 Assembly Language: a slightly more user-friendly language that directly corresponds to 

machine language 

Machine Language 
Machine language is the lowest and most elementary level of programming language and was 

the first type of programming language to be developed. Machine language is basically the only 

language that a computer can understand and it is usually written in hex. 

In fact, a manufacturer designs a computer to obey just one language, its machine code, which 

is represented inside the computer by a string of binary digits (bits) 0 and 1. The symbol 0 

stands for the absence of an electric pulse and the 1 stands for the presence of an electric 

pulse. Since a computer is capable of recognizing electric signals, it understands machine 

language. 



Advantages Disadvantages 

Machine language makes fast

 and 

efficient use of the computer. 

All operation codes have to be remembered 

It requires no translator to translate the 

code. It is directly understood by the 

computer. 

 
All memory addresses have to be remembered. 

 It is hard to amend or find errors in a program 

written in the machine language. 
 

Assembly Language- 2 Generation language 

Assembly language was developed to overcome some of the many inconveniences of machine 

language. This is another low-level but very important language in which operation codes and 

operands are given in the form of alphanumeric symbols instead of 0’s and l’s. 

These alphanumeric symbols are known as mnemonic codes and can combine in a maximum 

of five-letter combinations e.g. ADD for addition, SUB for subtraction, START, LABEL etc. 

Because of this feature, assembly language is also known as ‘Symbolic 

Programming Language.' 

This language is also very difficult and needs a lot of practice to master it because there 

is only a little English support in this language. Mostly assembly language is used to help in 

compiler orientations. The instructions of the assembly language are converted to machine 

codes by a language translator and then they are executed by the computer.  
High-level languages 3,4,5 Generation language 

High-level computer languages use formats that are similar to English. The purpose of 

developing high-level languages was to enable people to write programs easily, in their own 

native language environment (English). 

High-level languages are basically symbolic languages that use English words and/or 

mathematical symbols rather than mnemonic codes. Each instruction in the high-level 

language is translated into many machine language instructions that the computer can 

understand. 

 
Advantages Disadvantages 

 
High-level languages are user-friendly 

A high-level language has to be 

translated 

into the machine language by a translator, 

which takes up time 

They are similar to English and use English 

vocabulary and well-known symbols 

The object code generated by a translator 

might be inefficient compared to 

an equivalent 

assembly language program 

They are easier to learn  

They are easier to maintain  



They are problem-oriented rather

 than 'machine'-based 

 

A program written in a high-level language can 

be translated into many machine languages 

and can run on any computer for which there 

exists an appropriate translator 

 

The language is independent of the machine on 

which it is used i.e. programs developed in a 

high-level language can be run on any 

computer text 

 

 
Third generation language 

A third generation (programming) language (3GL) is a grouping of programming languages 

that introduced significant enhancements to second generation languages, primarily intended 

to make the programming language more programmer-friendly. 

 
English words are used to denote variables, programming structures and commands, and 

Structured Programming is supported by most 3GLs. Commonly known 3GLs are FORTRAN, 

BASIC, Pascal and the C-family (C, C+, C+ 

+, C#, Objective-C) of languages. 

Fourth generation languages 

 More like English than 3GLs 

 Non-procedural Programmers do not have to give step by step instructions to perform 

a function 

 Each statement in a 4GL language can be converted to 30 to 50 assembly instructions 

 Structured Query Language (SQL) : A standardized language often used to perform 

database queries and manipulations. 

 Oracle, Powerhouse, FOCUS, 4GL 
Object Oriented Languages 

 A revolutionary concept that changed the rules in computer programming 

 Organized around objects: Modeled after real-world objects (e.g. houses) 

 Polymorphism: One procedure can work with multiple objects. 

 Inheritance: an object in a particular class gets attributes of that class 

 Lower costs 

 Reduced testing 

 Faster implementation 

 

Fifth generation language 

 Knowledge-based programming: An approach to the development of computer 

programs in which you do not tell a computer how to do a job, but what you want it to 

do. 

 Natural Language, Artificial Intelligence 

 No programming experience required 

 



 

Operating system 

 

An operating system (OS) is a collection of software that manages computer hardware 

resources and provides common services for computer programs. The operating system is a 

vital component of the system software in a computer system. 

 
Functions of operating system 

An Operating System (OS) is an interface between a computer user and computer hardware. An 

operating system is a software which performs all the basic tasks like file management, memory 

management, process management, handling input and output, and controlling peripheral devices 

such as disk drives and printers.Some popular Operating Systems include Linux Operating System, 

Windows Operating System, VMS, OS/400, AIX, z/OS, etc.. 



 Memory Management 

 Processor Management 

 Device Management 

 File Management 

 Security 

 Control over system performance 

 Job accounting 

 Error detecting aids 

 Coordination between other software and users 

Memory Management 

Memory management refers to management of Primary Memory or Main Memory. Main 

memory is a large array of words or bytes where each word or byte has its own address. 

Main memory provides a fast storage that can be accessed directly by the CPU. For a program 

to be executed, it must in the main memory. An Operating System does the following activities 

for memory management − 

 Keeps tracks of primary memory, i.e., what part of it are in use by whom, what part 

are not in use. 

 In multi programming, the OS decides which process will get memory when and how 

much. 

 Allocates the memory when a process requests it to do so. 

 De-allocates the memory when a process no longer needs it or has been terminated. 
 

Processor Management 

In multiprogramming environment, the OS decides which process gets the processor when 

and for how much time. This function is called process scheduling. An Operating System does 

the following activities for processor management − 

 Keeps tracks of processor and status of process. The program responsible for this 

task is known as traffic controller. 

 Allocates the processor (CPU) to a process. 

 De-allocates processor when a process is no longer required. 

Device Management 
 

An Operating System manages device communication via their respective drivers. It does the 
following activities for device management − 



 Keeps tracks of all devices. Program responsible for this task is known as the I/O 

controller. 

 Decides which process gets the device when and for how much time. 

 Allocates the device in the efficient way. 

 De-allocates devices. 

File Management 
 

A file system is normally organized into directories for easy navigation and usage. These directories may 

contain files and other directions. 
 

An Operating System does the following activities for file management − 

 
Keeps track of information, location, uses, status etc. The collective facilities are often known as file system. 

 

 Decides who gets the resources. 

 Allocates the resources. 

 De-allocates the resources. 

 Other Important Activities 

Security − By means of password and similar other techniques, it prevents unauthorized access to programs 

and data. 
 

Control over system performance − Recording delays between request for a service and response from the 

system 

Job accounting − Keeping track of time and resources used by various jobs and users. 
 

Error detecting aids − Production of dumps, traces, error messages, and other debugging and 

error detecting aids. 

Coordination between other softwares and users − Coordination and assignment of compilers, 

interpreters, assemblers and other software to the various users of the computer systems. 

Types of Operating system 

Operating systems are there from the very first computer generation and they keep evolving 

with time. 

Batch operating system 

The users of a batch operating system do not interact with the computer directly. Each user 

prepares his job on an off-line device like punch cards and submits it to the computer 

operator. To speed up processing, jobs with similar needs are batched together and run as a 

group. The programmers leave their 



programs with the operator and the operator then sorts the programs with similar 

requirements into batches. 

Disadvantages 

 Lack of interaction between the user and the job. 

 CPU is often idle, because the speed of the mechanical I/O devices is slower than the 

CPU. 

Time-sharing operating systems 

Time-sharing is a technique which enables many people, located at various terminals, to use a 

particular computer system at the same time. Time- sharing or multitasking is a logical 

extension of multiprogramming. 

Processor's time which is shared among multiple users simultaneously is termed as time-

sharing. 

Multiple jobs are executed by the CPU by switching between them, but the switches occur so 

frequently. Thus, the user can receive an immediate response. 

Advantages 

 Provides quick response. 

 Avoids duplication of software. 

 Reduces CPU idle time. 

Disadvantages 

 Problem of reliability. 

 security and integrity issues of user programs and data. 

 Problem of data communication. 

Distributed operating System 
 

Distributed systems use multiple central processors to serve multiple real-time applications 

and multiple users. Data processing jobs are distributed among the processors accordingly. 

The processors communicate with one another through various communication lines (such as 

high-speed buses or telephone lines). These are referred as loosely coupled systems or 

distributed systems. Processors in a distributed system may vary in size and function. 

ADVANTAGES 

 With resource sharing facility, a user at one site may be able to use the resources 

available at another. 

 Speedup the exchange of data with one another via electronic mail. 



 If one site fails in a distributed system, the remaining sites can potentially continue 

operating. 

 Better service to the customers. 

 Reduction of the load on the host computer. 

 Reduction of delays in data processing. 

Network operating System 

A Network Operating System runs on a server and provides the server the capability to 

manage data, users, groups, security, applications, and other networking functions. The 

primary purpose of the network operating system is to allow shared file and printer access 

among multiple computers in a network, typically a local area network (LAN), a private 

network or to other networks. 

Examples of network operating systems include Microsoft Windows Server 2003, Microsoft 

Windows Server 2008, UNIX, Linux, Mac OS 

Advantages 

 Centralized servers are highly stable. 

 Security is server managed. 

 Upgrades to new technologies and hardware can be easily integrated into the system. 

 Remote access to servers is possible from different locations and types of systems. 

Disadvantages 

 High cost of buying and running a server. 

 Dependency on a central location for most operations. 

 Regular maintenance and updates are required. 

Real Time operating System 

A real-time system is defined as a data processing system in which the time interval required 

to process and respond to inputs is so small that it controls the environment. The time taken 

by the system to respond to an input and display of required updated information is termed 

as the response time. 

A real-time operating system must have well-defined, fixed time constraints, otherwise the 

system will fail. For example, scientific experiments, medical image systems, industrial control 

systems, weapon systems, robots, air traffic control systems, etc.



Computer Network: Networks: 

A computer network is created when several computers and terminal devices are 
connected together by data communication system. The set of computers may include 
microprocessors, mini computers, medium scale computers and large-scale computers. 
The set of terminal devices may include, dumb terminal, intelligent terminal, dumb as 
well as intelligent terminals etc. and miscellaneous devices such as modems, commonly 
used for data transmission. Each computer in a network can have its own processing 
capabilities and can also share computer hardware, programs, software, and data files. 

The three basic types of computer networks are as follows: 

 Local-area Networks. 

 Metropolitan-Area Networks. 

 Wide-Area Networks. 

 

Local-Area Network (LAN) 

A local area network (LAN) is two or more computers directly linked within a small 

well-defined area such as a room, office building, or a campus. A LAN can be made up of only 

microcomputer or any combination of microcomputer and large system. Main benefit of LAN 

is reduction of hardware and software costs because user can share several computers, 

peripheral devices such as laser printers, color printers, hard disk, and modems. Another 

benefit of LAN is the user can share the same data. 

A LAN generally consists of the following. 

1. Two or more computers. 

2. Software to control the operations of the computers. 

3. Peripheral devices such as modems, printers, plotters etc. 

4. Coaxial or fiber optic cables are usually used to connect the computers and there 

devices. 

5. A plug-in board to handle the data transmissions. 

Some LAN’s specifically requires all the computers to be of a certain brand while others 

allow a variety of brands to be connected. The number of computers in LAN varies widely 

from small LANs that connect two to twenty five computers, to large LANs that may connect 

more than 10,000 computers. 

LAN must get the data to its destination, transmit the data correctly, and prevent 

unauthorized users from gaining access to that data. 

Metropolitan-Area Networks: 

A Metropolitan-Area Network (MAN) is a network that is larger then a LAN. It is 

called metropolitan since it normally covers the area of a city. Different hardware and 

transmission media are often used in MAN because they 



must efficiently cover these distances (a few tens to about one hundred kilometers). 

 
Wide-Area Networks: 

A Wide-Area Network (WAN) is two or more geographically dispersed computer, 

linked by communication facilities such as telecommunication or microwave relays. In other 

words, one of the most significant aspects of Wide-area network while comparing it with the 

freedom of a local-area network is the involvement of public telecommunication authority. 

WAN is usually limited to use by large organizations and government agencies due to high 

costs involved in building and maintaining them. 

There are two specific categories of WAN, 
 

• Enterprise: An enterprise network connects all LAN’S of a single organization. The 
term is normally used for networks connecting extremely large organization, or for 
those that cross regional boundaries. 

 Global: By definition a global network is one that spans the earth. While global 

networks may not cover the entire globe, they cross multiple national boundaries and 

may include the networks of several organizations. 

 
NETWORK TOPOLOGY: 

Each computer or device in a network is called a node. The geometrical arrangement of 

computer resources, remote device and communication facilities are known as network 

topology. 

A network topology can be made in one of the five different topologies. 

1. Bus network 

2. Ring Network 

3. Star Network 

4. Tree Network 

5. Mesh Network 
 

1. Bus Network 

In a bus network, each computer is connected to a single communication cable via an 

interface and every computer can directly communicate with every other computer or device 

in the network. This topology is commonly used along with the local area networks. 

Advantages of the Bus Network 



 Short cable length and simple wiring layout: Because there is a single common data 

path connecting to all nodes, the bus topology allows a very short cable length to be 

used. This decreases the installation cost and also leads to a simple, easy to maintain 

wiring layout. 

 Reliable architecture: The bus architecture has an inherent simplicity that makes it very 

reliable from a hardware point of view. There is a single cable through which all data 

passes and to which all nodes are connected. 

 Easy to extend: Additional nodes can be connected to an existing bus network at any 

point along its length. 
Disadvantages of the Bus Network 

 Fault diagnosis is difficult: Although the simplicity of the bus topology means that there 

is very little that can go wrong, fault detection is not a simple matter. In most LANs 

based on a bus, control of the network is not centralized in any particular node. This 

means that detection of a fault may be performed from many points in the network. 

 Fault isolation is difficult: If a node is faulty on a bus, it must be rectified at the point 

where the node is connected to the network. 

 Repeater configuration: When a bus network has its backbone extended using 

repeaters, reconfiguration may be necessary, this may involve additional cable lengths 

and adjusting terminators, etc. 

 Nodes must be intelligent: Each node on the network is directly connected to the 

central bus, this mean that some way of deciding who can use the network at any given 

time must be performed in each node. It tends to increase the cost of the nodes. 

 

 
2. Ring Network 

In a ring network, several devices or computers are connected to each other in a closed 

loop by a single communication cable that is why a ring network is also called loop network. 

In the ring network, data must travel around the ring to each station in turn until they arrive 

at the required station. A thing can be unidirectional or bi-directional. In a unidirectional ring, 

data 



moves in one direction only, and in a bi-directional ring, data moves in both directions, but in 

only one direction at a time. 

 

Advantages of the Ring Network 

• Short cable length: This means that fewer connections will be needed, which will in 
turn increase network reliability. 

 No wiring closet space required: Since there is only one cable connecting each node 

to its immediate neighbors, it is not necessary to allocate space in the building for 

wiring closets. 

 Suitable for optical fibers: Optical fibers offer the possibility of very high speed 

transmission. Because traffic on a ring travels in one direction, it is easy to use optical 

fibers as a medium of transmission. 

 
 

Disadvantages of the Ring Network 
• Node failure causes network failure: The transmission of data on a ring goes through 

every connected node on the 

ring before returning to the sender. If one node fails to pass data though itself, the entire 

network has failed and no traffic can flow until the defective node has been removed from the 

ring. 

 Difficult to   diagnose faults: The fact that failure of one node will affect all others has 

serious implications for fault 

diagnosis. It may necessary to examine a series of adjacent nodes to determine the faulty 

one. 

 Network reconfiguration is difficult: It is not possible to shut down a small section of the 

ring while keeping the majority of it working normally. 



 Topology affects the access protocol: Each node on a ring has a responsibility to pass on 

data that it receives. This means that the access protocol must take this in to account. 

Before a node can transmit its own data, it must ensure that the medium is available 

for use. 

3. Star Network 

In star network, several devices or computers are connected to one centralized 

computer; the main disadvantage of star network is that none of the other computer can 

communicate with each other if the central computer breaks down. 

Advantages of the Star Network: 
 Ease of service: The star topology has a number of concentration points, these provides 

easy access for service of reconfiguration of the network. 

 One device per connection: In star topology, failure of a single connection typically 

involves disconnecting one node from an 

otherwise fully functional network. 

 Centralized control/problem diagnosis: The fact that the central node is connected 

directly to every other node in the network means that faults are easily detected and 

isolated. 

 Simple access protocols: Any given connection involves only the central node and one 

peripheral node makes the access protocols very simple. 

 

 

 

 

 

 

 

Disadvantages of the Star Network 

 Long cable length: Because each node is directly connected to the center, the star 

topology necessitates a large quantity of cable. 

 Difficult to expand: The addition of a new node involves a connection all the way to the 

central node. Problems can arise if a longer cable length is needed or an unanticipated 

concentration of nodes is required. 

 Central node dependency: If the central node in a star network fails, the entire network 

is rendered inoperable. 

4. Tree Network 

In a tree network, several devices or computers are linked in a hierarchical form. It is 

also known as hierarchical network. This type of distribution system is commonly used in 

the organization, where head quarters 



communicate with regional offices and regional offices communicates with district offices 

and so on. 

Advantages of the Tree Network 

 Easy to extend: Because the tree is, of its very nature, divided into subunits, it is easier 

to add new nodes or branches to it. 

 Fault isolation: It is possible to disconnect whole branches of the network from the 

main structure. This makes it easier to isolate a 
 

 
defective node. 

Disadvantages of the Tree Network 

 Dependent on the root: if the “head end” device fails to operate, the entire network is in 

operative. 

 

5. Mesh Network 

Mesh network has point-to-point connection between every device in the network. 
Each device requires an interface for every other device on the network. Mesh topologies are 
not usually considered practical, in addition unless each station frequently sends signals to all 
the other station, an excessive amount of network bandwidth. 

Advantages of the Mesh Network 

 Units affected by media failure: Mesh topologies resist media failure better than other 

topologies. Implementations that include more than two devices will always have 

multiple paths to send signals from one device to another. If one path fails, the 

transmission signals can be routed around the failed link. 

 Easy for troubleshooting: Mesh network are easy to trouble shoot because, each 

medium link is independent of all other devices. 



Disadvantages of the Mesh Network 

 Difficult   to install: Mesh networks are relatively difficult   to 

install because each device  must 

be  linked directly to all other devices, as the number of devices increases, the 

difficulty of installation increases geometrically. 

 Difficult to reconfigure: 

Mesh topologies are difficult to reconfigure 

for the same reasons that 

they are 

difficult to install. 

Communication 

Meaning: Communication is the activity of conveying meaningful information. 
 

(Or) 

Two-way process of reaching mutual understanding, in which participants not only exchange 

(encode-decode) information but also create and share meaning. 



Definitions of Communication: 

 Communication is meaningful interaction. 
 Communication is information sharing. 
 Communication is a link force. 
 Communication is understanding. 
 Communication is fundamental requisite of life. 

Important Characteristics of Communication: 

 It is a 2-way process. 
 Communication process happens between or among two or more parties. (Sender 

and Receiver) 
 Communication involves exchange of ideas, feelings, information, thoughts, and 

knowledge. 
 Communication involves mutuality of understanding between Sender and Receiver. 
 There are two types of Communication i.e., Verbal and Non-Verbal 

Communication. 

 
Forms/ Types of Communication: 

Verbal Communication: 

1. Oral Communication: Oral communication is information spoken by mouth; 
the use of speech. Some of the examples of Oral Communication are: Face to 
face communication, Telephonic Communication, Public Address System 
(Speech), Informal rumor mill (Grape Wine), Audio & Visual Media(Radio, TV), 
Lectures, Conference-Interchange of views, Meetings, Cultural Affairs. 

2. Written Communication: Communication by means of written symbols (either 
printed or handwritten). Some of the examples are: Orders, Instructions, 
Letters, Memos, Reports, Policy manuals, Information Bulletin, Complaint 
System, Suggestion System, etc 

3. Nonverbal Communication: 

4. Body Language includes facial expression, eye contact, postures, gestures, 
touch. 

5. Para Language is the way we say something rather than what we say, is another 
nonverbal code. 

6. Space and Time Language: 

Space Language includes surroundings (Design & Language). It communicates 
social status also. 



7. Sign Language: A sign language is a language which, instead of conveyed sound 
patterns, uses visually transmitted sign patterns. 

 
 

Media of Communication 

Fax 

A fax (short for facsimile) is a document sent over a telephone line. A fax machine 

consists of an optical scanner for digitizing images on paper, a printer for printing incoming fax 

messages, and a telephone for making the connection. 

 
Fax machines work by digitizing an image -- dividing it into a grid of dots. Each dot is 

either on or off, depending on whether it is black or white. Electronically, each dot is 

represented by a bit that has a value of either 0 (off) or 1 (on). In this way, the fax machine 

translates a picture into a series of zeros and ones (called a bit map) that can be transmitted 

like normal computer data. On the receiving side, a fax machine reads the incoming data, 

translates the zeros and ones back into dots, and reprints the picture. 

 
Though now largely redundant thanks to the efficiency of internet communication, fax 

machines were all the rage when they became widely affordable in the 1980s and 90s, allowing 

the transmission of paper documents over telephone wires. They are still considered a safer 

option than the internet for the transmission of sensitive material. 

 

TYPES OF FAX MACHINE 

The world of fax machines is full with a variety of options and brands. The main difference in a 
fax machine is the technology used by a specific company and the features included. On the 
basis of this there are a variety of fax machines which can be distinguished as below 

 
Inkjet fax machines 
Not so cheap solution the inkjet fax machines deliver relatively clear text at a low cost and 
make a good choice if incase you receive around 20- 30 faxes daily. The inkjet fax machine is 
not a cost effective solution for heave users and may prove costly in the 
recurring costs. 

Laser fax machines 

This type of fax machines are the costliest fax machines but due to the low cost on high usage 
prove cost-effective for heavy duty use. The laser fax machines use a laser or light emitting 
diode (LED) printing engine, which are indeed the same basic technology 
as laser printers. A toner is used by the laser fax machines which quickly produces high- quality 
images on plain paper. The Laser printing technology is quite reliable and it needs only few 
services beyond toner and paper. 



Thermal transfer fax machines 

The oldest of the block the thermal transfer fax machines come cheap if compared to inkjet or 

laser fax machines. In this fax machine thermal transfer technology uses heat to transfer ink from 

a ribbon onto a plain paper. Thermal transfer fax machines are quite reliable, inexpensive, and 

more common in the home-office market than true business fax machines. The problems 

generally faced with the thermal transfer fax machines is the poor print quality and consistent 

operational noise. 

 
 
Voice Mail 

Voicemail (also known as voice-mail, voice message, or voice bank) is a computer based 

system that allows users and subscribers to exchange personal voice messages, using an ordinary 

telephone. The term is also used more broadly to denote any system of conveying a stored 

telecommunications voice messages, including an answering machine. Most cell phones services 

offer voicemail as a basic feature. Voice mail systems make phone systems more powerful and 

flexible by allowing conversations and information to pass between parties, even when both are 

not present. 

 
In voice mail, a special device called CODEC ('coder-decoder') converts our analog signals into 

digital signals and then these digital signals are again converted into analog signals by the codec at 

the other end. Just like the E-mail, we can open up the voice mail and hear the voice message. 

 
E-Mail 

Electronic mail, commonly called email or e-mail, is a method of exchanging digital messages 

from an author to one or more recipients. Modern email operates across the Internet or other 

computer networks. Some early email systems required that the author and the recipient both be 

online at the same time, in common with instant messaging. Today's email systems are based on a 

store-and-forward model. Email servers accept, forward, deliver and store messages. Neither the 

users nor their computers are required to be online simultaneously; they need connect only 

briefly, typically to an email server, for as long as it takes to send or receive messages. Email 

consists of a username followed by the domain name, which depends on which domain he is 

creating and the user can protect his/her id by securing it with a password. 

 
 

Internet email messages consist of two major sections: 

Header — Structured into fields such as From, To, CC, Subject, Date, and other information about the 

email. 

 Body — The basic content, as unstructured text; sometimes containing a signature block at 

the end. This is exactly the same as the body of a regular letter. 



Creation of E-mail ID 

Follow these steps to create E-mail ID: 
 Decide in which site you want to create a new E-mail ID. 
 Go to your internet browser. 
 In the address bar type the address of the site you selected for creating the ID. 
 There comes the home page of the site that displays a link saying “Signup” or “Create a new 

account”, click on it. 
 There you get a form which needs details like your name, address, phone number, e- mail 

id, password etc. 
 Fill the entire form. 
 Submit the essentials. 
 Accept the agreement. 

There you have it your own e-mail ID on the web 
 

Advantages of E-mail: 

 
 Messages can be sent at whatever time of day suits the user. 
 Messages will be in the recipient’s mailbox within minutes. 
 Messages can be marked as urgent. 

 

Group Communication: 

Group communication is the process by which an information is transmitted between in- group 
and /or organizations so that a good understanding response can be formed. 

 

Objectives of group communication: 

 
 To instruct, solve problems and take decisions. 
 To present the result of original research. 
 To share knowledge and for getting viewpoints. 
 To exchange information among the different groups. 

 To discuss various aspects of a problem for audience. 
 To interchange ideas through conversation, co-operative thinking. 

 

Major forms of Group Communication: 

 Meeting 
 Group Discussion 
 Tele Conferencing 
 Video Conferencing 
 File Exchange 



Meeting: Meeting refers to two or more people together for the purpose of discussing 

predetermined subject matter. In an organization, meetings are an important vehicle for human 

communication. 

Every meeting is called for the purpose and it is this purpose, which gives form to a meeting. 

Purpose of a meeting: 

 Meeting for informational purpose: 

 To communicate important proposal. 

 To explore the concepts or ideas. 

 To present the report. 

 To provide the feedback. 

Meeting for decision-making purpose: 

 To reach a group discussion. 

 To solve the problems. 

 To decide strategies 

 To negotiate an offer or contract. 

Types of meeting: 

Status meeting: It is leader-led, which about reporting by one-way communication. Work 

meeting: Those meeting which produce a product or intangible result such as a decision. 

Team meeting: A meeting among colleagues working on various aspects of a team project. Staff 

meeting: A meeting between a manager and those that report to him/her is called staff meeting. 

Ad- hoc meeting: A meeting called suddenly for special purpose to get immediate result. Board 

meeting: The meeting which is called by the board of directors in an organization or institute. 

Management meeting: A meeting held on among managers or authorities. 

Group Discussion: It is the process of conducting face to face meeting through free oral 

interaction to share and discuss ideas for getting a decision or solution to a problem. 

Tele Conferencing: 
The word ‘tele’ means distance. The word ‘conference’ means consultations and 

discussions. Through tele-conferencing, two or more locations situated at a distance, are 

connected so that they can hear or both see and hear each other. The interactions occur in real 

time. This means that the learners/participants and the resource persons are present at the same 

time in different locations and are able to communicate with each other. 

Terms such as audio conferencing, telephone conferencing and phone 

conferencing are also sometimes used to refer to teleconferencing. 



Internet teleconferencing includes videoconferencing and Internet Telephony. Internet telephony 

involves conducting a teleconference over the Internet or a Wide Area Network. One key 

technology in this area is Voice over Internet Protocol (VOIP). Popular software for personal use 

includes Skype, Google Talk, Windows Live Messenger and Yahoo Messenger. Uses of Tele-

conferencing: 

 Teleconferencing reaches large or sparsely-populated areas: It offers opportunities 

for people in outlying regions to participate. People participate either from home or 

from a local teleconferencing center. 

 Teleconferencing provides broader access to public meetings, as well as widening 

the reach of public involvement. 

 Teleconferencing saves an agency time and travel costs. Without leaving their 

home office, staff members can have effective meetings that reach several people who 

might not otherwise be able to come together. Teleconferencing reduces the need for 

holding several meetings in different geographic areas, thereby decreasing public 

involvement costs, particularly staff time and travel. 

 A wider group of participants means a broader range of ideas and points of view. 

Audio interaction makes dialogue more lively, personal, and interesting. It enables 

people with disabilities, parents with childcare conflicts, the elderly, and others to 

participate without having to travel. 

 
Video - Conferencing 

A videoconference or video teleconference is a set of interactive telecommunication 

technologies which allow two or more locations to interact via two- way video and audio 

transmissions simultaneously. It is also called 'visual collaboration’. 

Videoconferencing uses telecommunications of audio and video to bring people at 

different sites together for a meeting. This can be as simple as a conversation between two people 

in private offices (point-to-point) or involve several sites (multi-point) with more than one person 

in large rooms at different sites. 

 
The other components required for a videoconferencing system include: 

 Video input : video camera or webcam 

 Video output: computer monitor , television or projector 

 Audio input: microphones, CD/DVD player or cassette player 

 Audio output: usually loudspeakers associated with the display device or telephone 

 Data transfer: analog or digital telephone network, LAN or Internet 



 Computer: a data processing unit that ties together the other components, does the 

compressing and decompressing, and initiates and maintains the data linkage via the 

network. 

 
There are two kinds of videoconferencing systems: 

 
 Dedicated systems have all required components packaged into a single piece of 

equipment, usually a console with a high quality remote controlled video camera. These 

cameras can be controlled at a distance to span left and right, tilt up and down, and 

zoom. 

 Desktop systems are add-ons to normal PCs, transforming them into 

videoconferencing devices. A range of different cameras and microphones can be used 

with the board, which contains the necessary codec and transmission interfaces. 

Videoconferences carried out via dispersed PCs are also known as e- meetings. 

Videoconferencing is commonly used for: 
 

 Interviewing prospective students and staff 

 Research group meetings 

 Business meetings 

 Teaching and distance learning 

 Presentations 

 Seminar presentations to remote audiences 

 Public launches of new research projects 



UNIT-IV 

MS – POWERPOINT & MULTIMEDIA 
MS POWERPOINT: Features, Advantages and Applications of MS Power Point, Parts of MS Power point Window, 

Menu and Tool bars, Creating Presentations through Auto content wizard, Templates and Manually, Slide Show, 

Saving, Opening and Closing a Presentation. 

MULTIMEDIA: Meaning, Purpose, Usage and Application, Images, Graphics, Sounds and Music, Video Presentation 

Devices, Multimedia on Web. 

 
MS POWERPOINT: 

 

Microsoft PowerPoint is presentation software. It helps in quickly creating attractive and effective slide show 

presentations. Each presentation can consist of as many slides as the user wants. Each slide can carry text, graphics 

and sound. The slides can be animated to make them more attractive. 

PowerPoint lets users create and edit individual pages called slides. There can be large number of such 

slides in presentation. PowerPoint provides ready-to-use templates for slides. PowerPoint can be used to create: 

 Video slide show on the computer screen. 

 Color transparencies for overhead projector. 

 Black and white transparencies for overhead projector. 

 Speaker notes, remainder notes and back up information. 

 Printed handouts. 

 Presentation files 

 
FEATURES OF MS POWERPOINT: 

 

 Better Organization charts and New Diagrams Types: 

Organization charts now use the drawing tools in Power Point, resulting in smaller fields sizes and 

easier editing. Also, Power Point includes a new gallery of common conceptual diagrams. You can customize 

these pre-drawn diagrams with text animation effects and a variety of formatting styles. Choose from 

diagrams such as Pyramid for showing the building blocks of a relationship, Radial for showing items in 

relation to a core element and more. 

 Save Background or Selection as picture: 

When you want to create a presentation using the drawing tools in Power Point, you can save it as a 

picture by right-click it. You can also save a texture or picture background from a slide in the same way that 

makes it easy to reuse these graphic elements. 

 Insert Multiple Picture: 

When you want to insert pictures from files on your hard disk drive, you can select multiple pictures 

and insert them all at once. 

 Picture Rotation: 

You can rotate and flip types of image file in a Power Point presentation including bitmaps. 

 Support for Audio and Video: 

Sound and videos that you include in a presentation broadcast are heard and seen by the audience, 

both in real-time or when archives. 

 Error Prevention and Recovery: 

Documents you are working on can be recovered if the program encounters an error or stops 

responding. The documents are displayed in the Document Recovery task pane the next time you open the 

program. 



 Animation: 

Different animation techniques are also available in the slides. The letters and pictures will fly from 

top to bottom and from left to right. Not only one technique, we can have many animation options. We can 

also get preview of various animation effects. 

 
 Speaker Notes: 

Speaker notes are the notes that can be included in the bottom of the slide so that new ideas can be 

discussed during presentation. 

 Other Features: 

MS-Power Point includes many other features like macros, changing the colors to the slides, fonts 

etc. We can also change the slide numbers from any direction using slide sorter command. 

 
ADVANTAGES OF POWER POINT: 

 

There are many advantages of computerized presentations. 

1. The slides can be prepared for different types of audiences i.e., literates, illiterates, children, old 

people etc. 

2. They can be run automatically. There is no manual interference for running power point show. 

3. There is no problem of getting slides out of order. 

4. We can even take printouts of presentations and can be distributed to the audience. 

5. The audience will easily be attracted by the colorful slides with sound and animation techniques. 

6. The Built-in design templates allow the people to create colorful slides very easily. 

7. If we want to change a part of presentation, we need not change all the slides. We can change all 

slides by changing the Master slide. 

 
APPLICATIONS OF MS PWERPOINT: 

 

The main purpose of MS PowerPoint is to enable the user to create dynamic, informational slide shows through 

the use of text, graphics, and animation. 

 Slide shows created with the software are often displayed on projection screens for business, training, or 

educational presentations, although they can be distributed as stand-alone files. 

 PowerPoint Presentations are a way of attracting audience towards your views and arguments. It is one of 

the most helping factors behind success of every meeting. 

 The most popular uses of power point presentations are in modern days learning, corporate training 

sessions, business and marketing meetings, and sales gatherings. 

 Learning Solutions 

Power point presentation combines audio and visual both aspects, making it easier to understand for 

audience. Even the normal teaching or training becomes interactive by just using presentations in lectures. 

These days school, colleges and institutions are providing tailor made presentations to students for different 

topics in syllabus of study. That makes learning easier and interactive for students. 

 Corporate Training Session 

Power point is an essential ingredient of every corporate training session. Top executives and 

manager (marketing and sales) use this powerful tool to train their junior's or associates to give them better, 

interactive and more effective training. It's always beneficial and less time consuming for corporate trainers, 

if they use these tools in their sessions, it generates more results. 



 Marketing Strategy 

Powerful tools and options present in Microsoft power point, makes it easier for people in marketing, 

advertising, and sales to make presentations for motivation of their subordinates. Inclusion of different types 

of charts, images, clip-arts, other graphical structures, makes a presentation eye catchy. Animation and sound 

effects add extra emphasis on these presentations making them look more interactive. 

 

 
PARTS OF MS-POWERPOINT WINDOW: 

 

The parts of the MS-Power point window are: 

 
1) Standard buttons- found at the top under the title bar of MS-PowerPoint 2007, they are the save, undo and 

redo buttons. 

2) Home Menu Toolbar- located beneath the title bar, it‘s a toolbar menu compose of a group of command 

buttons, namely: 1. Clipboard where the cut/ copy/paste located,2. Slides where the new slide, reset, delete, 

layout located, 3.Font where the font style, font size font color and other formatting of text located, 4. 

Paragraph where the alignment, bullets,numbering,and indention of paragraph located,5. Drawing where the 

autoshapes and other format of shaped,alignment and fill color of object located, and 6. Editing where the 

find, replace, and select located. 

3) Insert Menu Toolbar- located next of home menu, it‘s a toolbar menu compose of a group of command 

buttons, namely: 1. Tables where you can insert table for your presentation, 2. Illustration where you can 

insert your own picture, clipart, photo album, shapes, smart art and chart, 3. Links where you can link using 

the hyperlink or internet and put a hover action of your presentation, 4. Text where you can insert text box, 

header and footer, word art, date and time, slide number, symbol and object,5. Media Clips where you can 

insert movie and sound for your presentation. 

4) Design Menu Toolbar- this is next of the insert menu, its a toolbar menu compose of a group of command 

buttons,namely:1. Page Setup where you can Page Setup, Orientation and Margin,2. Themes where you can 

select a custom themes that will automatically apply once you hover your mouse on it,and 3. Background 

where you can apply background styles and hide background graphics of your presentation templates(slides) 

5) Animation Menu Toolbar- located next of design menu, it‘s a toolbar menu compose of a group of 

command buttons, namely: 1. Preview where you can preview you slide, 2. Animations where you can apply 

motion and effect or custom animation, and 3. Transition of this slide where you can apply continues slide 

and setup time, sound, and speed for your slide presentation. 

6) Slide Show Menu Toolbar- next of animation menu, it‘s a toolbar menu compose of a group of command 

buttons, namely:1. Start slide show where you can start your on mouse click and transition slide 

presentation, 2. Setup where you can setup show, rehearse and record narration, and 3. Monitors where you 

can increase and decrease resolution of monitor screen, show presentation on, and use presenter view. 

7) Review Menu Toolbar- next of slide show menu, its a toolbar menu compose of a group of command 

buttons, namely:1. Proofing where you can check your spelling, research, thesaurus, translate, and 

language,2. Comments where you can show mark up, new comment, edit comment, delete, previous and next 

of your presentation slide. 

8) View Menu Toolbar- located next of review menu,its a toolbar menu compose of a group of command 

buttons,namely:1. Presentation Views where you can set normal, slide sorter, note pages, slide show, slide 

master, handout master, and notes master, 2. Show Hide where you can apply ruler,grid lines,and message 

bar,3. zoom where you can increase and decrease size of your 



slide without using the zoom in/zoom out sliding bar of the bottom right,4. Color gray Scale where you can 

apply or change the color background of graphics/image/picture,5. Window where you can apply or set new 

window, arrange all, cascade, and move split windows, and 6. Macros where you can use the macros 

presentation slide, 

9) Format Menu Toolbar- this is next of view menu,its a toolbar menu compose of a group of command 

buttons,namely:1. Insert shapes where you can select/format auto shapes, 2. Shape styles where you can 

format or change the color, outline, effects, and fill color of the autoshapes, 

3. Word art styles where you can change the style of the font using the word art format, 4. Arrange where 

you can arrange the autoshapes and font, and 5. Size where you can set up the size of the auto shapes and 

font area of the presentation slide. 

10) File Menu Button- It‘s the logo of the Microsoft Corp., it‘s a rounded or circle form, position on the top left 

of the user interface. This is use as the file menu toolbar where you can save, new template, open, print and 

etc. 

11) Sorter Panel- located left side of the presentation template. This use to arrange or sort in order the slide 

presentation. 

12) Status Bar- located below left of the window. This is use to indicate the number of slides and will works of 

the vertical scroll bar. 

13) Presentation Slide- the big part of the windows, this is the presentation template where the slides located and 

perform the different slide application. 

14) Zoom In Zoom Out Sliding Bar- located right side bottom of the window, this use to increase and decrease 

the size of the presentation slide without using the command button of a toolbar menu. 

15) Guide Bar or Note Bar- this use to apply a presentation slide note of the application package 
 



CREATING PRESENTATIONS THROUGH AUTO CONTENT WIZARD: 

 

 
PowerPoint has an AutoContent Wizard that can help to create our presentation. After we choose the type of 

presentation we want to crate, the wizard uses the information you provide to help you create a presentation. We 

can replace the text in our own words. 

Presentations created with the AutoContent Wizard include suggestions on where to put different kinds of 

information and how to organize it into an effective presentation format. 

 
To starts the AutoContent Wizard, follow these steps: 

1. Open PowerPoint. 

2. Click on from AutoContent Wizard in the Task Pane. 

3. If the Task Pane is not visible, click on View from the menu bar and then click on Task Pane. 

4. Follow the instructions in the wizard and make your choices or provide information when asked. 

5. When the wizard is completed - finish the presentation by filling in the slides with text and images. 

 

 
CREATING PRESENTATIONS BASED ON A DESIGN TEMPLATE: 

 
We can reuse and apply existing templates to give a jump-start to our presentation using templates. 

There are many ways to use a template that you like and want to reuse. 

 

1. Click the Microsoft Office Button  , and then click New. 

2. In the New Presentation dialog box, do one of the following: 

 

Under Templates, do one of the following: 

 To apply a template that you've recently used, click Blank and recent, click the template that you 

want, and then click Create. 

 To apply a template that you've installed to your local hard drive, click Installed Templates, and then 

click Create. 

 To create (and apply) a new template based on another template that installed on your local hard 

drive, click New from existing, and then click Create New. 

 To apply a template that you've saved to C:\Program Files\Microsoft Office\Templates\, click My 

templates, select a custom template, and then click OK. 

 To download and apply a template from Office Online, under Microsoft Office Online, click a 

template category, select a template, and then click Download. 

3. Add the content you want. 

4. When you finish, click Save on the File menu. 

5. Name your presentation, and then click Save. CREATING PRESENTATIONS MANUALLY 

One can start a presentation from a blank slide. This manual provides the steps to create a new presentation from a 

blank slide: 

6. Open Microsoft Office PowerPoint 2007 from the start menu on your computer. 

7. Click on the Microsoft Office Button in the top left corner. 

8. Click on New 

9. Click Blank Presentation to open a blank PowerPoint and to start a new presentation. 

10. Click New Slide to select a slide template from the toolbox under the Home tab. This allows you to select the 

layout of the slide. 



11. Click in the textbox to enter the title and text to your slide. 

12. To add more slides, select the slide immediately before where you want the new slide 

13. Click the New Slide button on the Home tab to make a selection. 

14. Alternatively, one can duplicate current slides in the presentation by clicking Duplicate Selected Slides under 

the New Slide button on the Home tab. 

15. Once a template is selected, one can add a theme. Click the Design tab to make a selection from the displayed 

themes. To allow for consistency, it is recommended that the same design template is applied to the entire 

presentation 

16. Repeat steps 8 through 10 to create multiple slides until the PowerPoint presentation is complete. 

17. In order to save, click the Microsoft Office Button. Saving your PowerPoint prevents data loss. 

18. Click View and then Slide Show to view the slide show for presentation. When you present the slides, this 

allows for full screen view of each slide. 

 
Changing slide layout: 

It is possible to change slide layout of a presentation already created. The steps are: 

1. In normal or slide sorter view, select the slide you want to change. 

2. On the Formatting toolbar, click common Tasks, and then click slide layout. 

3. Use the scroll bar to view all layouts, click the one you want, and then click apply. 

4. Rearrange any overlapping or hidden objects to fit the new layout. 

 

Slide show: 
 

PowerPoint allows us to start slide show from the first slide or from any slide within the slide show. 

To start a slide show: 
1. Select the Slide Show tab. 

2. Click the From Beginning command in the Start Slide Show group to start the slide show with the first 

slide. 

 
 

 

3. We can start the slide show from the slide we prefer by selecting the slide and clicking on From Current Slide 

from the Start Slide Show group. 

4. Another option for starting the slide show is to select Slide Show view at the bottom of the window. 



To advance and reverse slides: 

1. mouse over the bottom-left of the screen. A menu will appear. 

2. Click the right arrow to advance slides and the left arrow to reverse slides. 

 
 

3. You can also use the arrow keys on your keyboard to advance and reverse slides. 

 

 

 

 

 
To stop or end a slide show: 

 
1. To end a slide show, select the menu box options command and click End Show. 

2. we can also press the Esc key at the top left of your keyboard to end the show. 

 

 

 

SAVING , OPENING AND CLOSING A PRESENTATION 
 

Opening PowerPoint 

 
To open PowerPoint in Windows, click on the 

 
1. Start button --> Programs --> Microsoft PowerPoint 

 
OR 

 
Double-click on the PowerPoint icon on the desktop 

 
3. When PowerPoint 2007 is opened, a blank Title slide appears by default as the first slide in your new 

presentation. You can start a new presentation when you first open PowerPoint or after PowerPoint is already 

open. 

4. To change the layout of an open slide, click on the Layout button in the Home tab. 

INSERTING, EDITING AND DELETING SLIDES: 

 To insert and format text in a slide: 

 
Step 1: 

Click inside a placeholder. 

Step 2: 

Enter text. You may use the formatting toolbar at the top of the PowerPoint window to apply various formats to your 

selected text. You may notice this toolbar is identical to the one used in Microsoft Word. 
 



Step 3: 

When you are finished entering text, click outside the placeholder on some ―empty space.‖ 

 
 To delete text : 

 
Option #1: Highlight the text you want to delete by dragging the cursor over the letters, and press the delete key. 

 
Option #2: Click on the selection rectangle around the text so that its border changes from hatch marks to dots, and 

then press the delete key. 

 
 To insert a new slide: 

 
Option #1: Go to Insert->New Slide. A blank slide will appear in the workspace, positioned after the selected slide or 

slide you were viewing. 

 
Option #2: Click on the "New Slide‖ button on the formatting toolbar at the top of the PowerPoint window. 

 

 

Option #3: On the Slides pane (off to the left), position your cursor to the point in the presentation where you would 

like the new slide to appear (i.e. between slides, at the beginning of the presentation, or at the end of the presentation). 

Right click, and choose ―New slide‖ from the menu that appears. 

 

 To delete a slide :Option #1: Go to Edit->Delete Slide. The current slide will disappear from the workspace. 

 
Option #2: On the Slides pane (off to the left), click on the slide you would like to delete, and then hit the 

<Delete> key. 



SLIDE: 
 

A slide is a page, document or template where all the content of a presentation is written.    It is just like a 

page of paper or page of slide show. A single page in the slide show presentation is known as a slide. A slide is a 

container, which can contain – texts, pictures, charts, drawing and animations ECT. which are also known as objects. 

TYPES OF SLIDES: 
 

Power Point offers 27 different types of slide layouts divided into four categories: 

 Text Layout - A Text layout slide contains only text. The slide might contain one or two columns of text, 

with or without a title. 

 Content Layout – Content layout slides can contain up to four pieces of content in several arrangements. 

Content is a graph, a photo, an organization chart, or some other visual element. 

 Text and Content Layout – The seven text and content layouts place text and content on a slide in various 

arrangements. 

 Other Layout – The other layouts don‘t fit the other categories. For example, you can create a slide with a 

single table, diagram, or organization chart. You can also create combinations with text, media clip art, and 

charts. 

Depending on which method you use to create a new presentation, it might already contain slide layouts. If you 

want to look at these layouts before you create a presentation, apply them directly to slide, or change a layout, 

choose Format, Slide Layout to open the Slide Layout task pane. 

 
The lists of slide layouts are as follows - 

 
1. Title Slide - Used at the start of your presentation, or to divide sections of your presentation. 

2. Title and Content - The default slide layout and the most commonly used slide layout. 

3. Section Header - Use this slide type to separate different sections of the same presentation, rather than use 

an additional Title slide. It can also be used as an alternate to the Title slide layout.Two Content - Use 

this slide layout if you wish to show text in addition to a graphic content type. 

4. Comparison - Similar to the Two Content slide layout, but this slide type also includes a heading text box 

over each type of content. Use this type of slide layout to - 

o compare two types of the same content type (for example - two different charts) 

o show text in addition to a graphic content type 

5. Title Only - Use this slide layout if you want to place only a title on the page, rather than a title and subtitle. 

You can then insert other types of objects such as clip art, WordArt, pictures or charts if desired. 

6. Blank - A blank slide layout is often used when a picture or other graphic object that needs no further 

information, will be inserted to cover the whole slide. 



7. Content with Caption - Content (most often a graphic object such as a chart or picture) will be placed on 

the right side of the slide. The left side allows for a title and text to describe the object. 

8. Picture with Caption - The upper part of the slide is used to place a picture. Under the slide you can add a 

title and descriptive text if desired 

 
DIFFERENT VIEWS OF SLIDE: 

Microsoft Power Point comes with different views to help the user while creating presentations. They are: 

1. Normal view, 

2. Slide sorter view 

3. Slide show view 

1. Normal View: 

This is the default view. It displays three panes; the Normal View Pane, which includes the Outline and 

Slides tabs, the slide pane in the centre, and the Notes pane beneath it.: 

 Outline Pane: 

This view helps in organizing and developing the content of the presentation. Users can type the text to be 

presented and rearrange bullet points, paragraphs and slide. 

 Notes Pane: 

This pane can be used to add speaker notes or other relevant information to share with the audience. 

If graphics have to be added to the notes, the users must add the notes in notes page view. 

 Slide pane: 

The slide pane is the largest of the three panes. You can add text, graphics, tables, charts, and other objects 

to your presentation on the slide pane. 

 
2. Slide sorter view: 

Slide Sorter view displays miniature previews of all the slides in your presentation, making it easier for you 

to organize them. 

 
3. Slide show View: 

Slide show view displays your slides as they would appear in a slide show, full-screen, without any menus, 

toolbars, or other features. 

 

FORMATTING SLIDES:The slides designed in Power Point can be formatted with slide text formatting, color 

scheme formatting, adding transition, adding animation, and recording voice narration etc. 

 
 Adding transitions to a slide show: 

 
1. In slide or slide sorter view, select the slide or slides you want to add a transition to. 

2. On the slide show menu, click slide transition. 

3. In the effect box, click the transition you want, and then select any other options you want. 

4. To apply the transition to the selected slide, click apply. To apply the transition to all the slides, click apply 

to all 

5. Repeat the process for each slide you want to add a transition to. To view the transitions, on the 

slide show menu, click animation preview. 

 
 Changing slide background: 

You can change the appearance of your slide background by changing its color, shade, pattern, or texture. 

You can also use a picture as a slide background, but you can use only one type of background on a slide or 

master. For example – you can have a shaded background, a textured background, or a picture as the back 

ground, I but you can use only one of these on a single slide. 



When you change the backgournd, you can apply the change to only the current slide or to all the slides and 

the slide master. 

 
 Formatting slide with color scheme: 

The slides can be rearranged slide sorter view. Slides can be dragged or cut and paste can be used to cut a 

slide and past it in any order in the presentation file. If the user is satisfied with the presentation created, it should 

be saved by clicking ‗Save‖ on File menu. Type a file name and click ‗Save‘. Thus, a presentation is created and 

saved in PowerPoint. It can be reviewed, rehearsed and modified to make them more attractive. The user can also 

ad narration to the presentation. Save the presentation after all the modifications are carried out. 

 
INSERTION OF OBJECTS AND CHARTS: 

 

 Inserting Slide Number, data and Time: 

1. On the View menu, click Header and Footer. 

2. To add the information to your slides, click the Slide tab. 

To add the information to notes pages and handouts, click the Notes and Handouts tab. 

3. Select the options you want. 

4. To add the information to only the current slide, click Apply. To add it to all slides in the presentation, click 

Apply to All. 

 
 Insert a Picture from the Clip Gallery: 

1. Display the slide you want to add a picture to. 

2. Click Insert Clip Art on the Drawing toolbar, and then click the pictures tab. 

3. Click the category you want. 

4. Click the picture you want, and then click Insert Clip on the shortcut menu. 

5. When you are finished using the Clip Gallery, click the Close button on the Clip Gallery title bar. 

 Insert an Animated GIF Picture on a Slide: 

1. Display the slide you want to add the animated GIF Picture to. 

2. Do one of the following. 

To insert an animated GIF picture from the Clip Gallery, Click Insert Clip Art on the Drawing 

toolbar and then click the Motion Clips Tab. 

To insert an animated GIF Picture from a file, on the Insert menu, point to Picture, and then click 

From File. 

3. Do one of the following: 

If you clicked Insert Clip Art in step2, click the animated GIF picture you want to add to your slide, 

and then click Insert Clip on the menu that appears. 

If you clicked From File (Insert menu, picture submenu) in step2, locate the folder that contains the 

animated GIF picture you want to insert, and double-click the picture. 

4. To preview how the animated GIF picture will appear in the slide show, click Slide Show at the lower left of 

the MS PowerPoint window. 

 
 Insert an Organization Chart: 

1. Display the slide you want to add an Organization chart to. 

2. On the Insert Menu, point to Picture, and then click Organization Chart. 

3. Use the Organization chart tools and menus to design your chart. 

4. To return to PowerPoint, click Exit and Return to presentation on the Organization Chart File Menu. 



CUSTOM ANIMATION AND TRANSITION: 
 

There are certain steps to be followed: 
 

1. Select the slide for which we want to apply animation. 

2. Click on slide show > Custom Animation. 

Consequently, the Custom Animation Dialogue box appears. 
 

3. Click on the text or picture and click on ADD EFFECTS in the above custom animations. Consequently some 

types of effects appear. 

4. Select one effect. Again some more 



Unit IV MS EXCEL 

Features: Features of MS Excel- spread sheet/worksheet, workbook, cell pointer, cell address- auto 

Fill - sorting & Filtering - pivot table and Pivot Chart Reports 

Protection: protect worksheet, protect workbook, share workbook, track changes. Charts: charts 

elements, Titles, Legend, data lables,creating new charts,Formatting the chart, Types of charts, using 
the chart templates. 

Data outline: Group, ungroup, and subtotal. 
Data Tools: Data validation and consolidation 

 
 

Introduction: Microsoft Excel is a spreadsheet program that is used to record and analyze 

numerical data. Think of a spreadsheet as a collection of columns and rows that form a table. MS 

Excel is a Windows-based application package that can be used to automate tasks such as calculation 

and analysis of data, automate financial statements, business forecasting, transaction registers, 

inventory control, etc. It provides multiple facilities, such as making graphs and charts, analyzing 

situations, and helps users at the managerial level in taking decisions. 

FEATURES OF MS EXCEL 

The features provided by Excel are very useful for managers as well as the supervisors in any 

type of organization and help them to execute their complex tasks with a minimum effort. It is 

extensively used in financial organizations. The features of MS Excel are as follows: 

1. Functions and formulas: The built-in formulas are called functions. MS Excel provides analyzing 

data and manipulating text by using different functions. Users can easily calculate sum, interest, 

average, etc. by using built-in functions. This can be done either by typing in the function-based 

formulas or by using function wizards. Formulas are widely used in simple computing (such as 

addition, subtraction, multiplication and division) and advanced computing. They provide the 

power to analyze data extensively. 

2. Auto-calculation: MS Excel spreadsheet allows a user to automatically recalculate the whole 

worksheet every time a change is made in a single cell. 

3. Charts & Graphs: One of the most important features of MS Excel is a chart. MS Excel allows 

users to view data entered as tables in a graphical form as charts, which helps a user to easily 

understand, analyze, and compare data. 

4. Entering Data in Series: A user can fill a range of cells either with the same value or with the 

series of values. This can be done using the Autofill handle (small square on the bottom-right 

corner of the active cell). 

5. Sorting: This feature allows the data to be sorted either in ascending or descending order. 

6. Filtering: Using AutoFilter to filter data is a quick and easy way to find and work with a subset of 

data in a range of cells or table column 

7. Pivot Table & Pivot Charts: Use a PivotTable report to summarize, analyze, explore, and present 

summary data. Use a PivotChart report to visualize this summary data in a 



PivotTable report, and to easily see comparisons, patterns, and trends. Both a PivotTable report 

and  a PivotChart report  enable you to  make informed  decisions about critical data in your 

enterprise. 

8. Data Validation: Prevents invalid data entry in a worksheet. 

 
Basic Terms: 

Workbook: when you open Excel, a new file is created called Book 1 (until you name it differently). 

It is called ―workbook‖ and it is initially made up of three Worksheets. When MS Excel is opened, by 

default a workbook is opened with three worksheets named sheet1, sheet2, sheet3. 

Worksheet: A worksheet consists of cells organized into columns and rows and is always a part of 

workbook also called as spread sheet. In Microsoft excel a workbook is a file in which we can store 

the data. 

 

C ell: The worksheet is divided into number of columns and rows with labels. The intersection of a 

column and a row is a cell. A cell can be identified by its cell reference composed of the column 

name followed by the row number. Eg: D4 where D is column name and 4 is row number. 

 A workbook contains 3 worksheets by default. We can add any number of worksheets to 

a workbook. 

 There are 16,384 columns (from A to XFD) and 1,048,576 rows (from 1 to 

1048576) in an Excel worksheet. 

 Column width is 255 characters and row height can be up to 409 points. 

 A cell can contain 32,767 characters. 

AUTO FILL 

An amazing and often underutilized feature of Excel is the Auto fill. Auto fill is the use of the fill 

handle to copy data and sequences across a range of cells. 

To fill a range of cells: 

 Select the cell with the content you wish to copy 

 Point at the black square that appears in the bottom right corner of the cell, until your mouse 

pointer becomes the fill handle 

 Click and drag in the direction of the range you wish to fill. 

 Excel will copy the contents of the cell across the range that you select. This will also work 

with dates. 

 This feature becomes very powerful when used with cells containing formulas. A lot of time 

can be saved by copying formulas across a range of cells. 

Data Sorting: 

Sorting data in MS Excel rearranges the rows based on the contents of a particular column. You may 

want to sort a table to put names in alphabetical order. Or, maybe you want to sort data by Amount 

from smallest to largest or largest to smallest. 

To Sort the data follow the steps mentioned below. 



 Select the Column by which you want to sort data. 

 Choose Data Tab » Sort Below dialog appears. 

 If you want to sort data based on a selected column, Choose Continue with the 

selection or if you want sorting based on other columns, choose Expand Selection. 

 You can Sort based on the below Conditions. 

o Values − Alphabetically or numerically. 

o Cell Color − Based on Color of Cell. 

o Font Color − Based on Font color. 

o Cell Icon − Based on Cell Icon 
 

Single column sorting: 
 

To sort on one column, execute the following steps. 

1. Click any cell in the column you want to sort. 

2. To sort in ascending order, on the Data tab, in the Sort & Filter group, click AZ or ZA. 
 

Multiple Columns Sorting: 

To sort on multiple columns 

1. On the Data tab, in the Sort & Filter group, click Sort. The Sort dialog box appears. 

2. Select column name from the 'Sort by' drop-down list. 

3. Click on Add Level. 

4. Select another column from the 'Then by' drop-down list. 

5. Click OK. 

Records are first sorted by column name given in sort by and then sorts by another columngiven 

in then by drop down list first and Sales second. 

 

4. Sort By Color: 
 

1. Click any single cell inside a data set. 

2. On the Data tab, in the Sort & Filter group, click Sort. The Sort dialog box appears. 

3. Sort by Last Name (or any other column), sort on Cell Color (you can also sort on Font Color and 

Cell Icon), and select the green color for the first level. 

4. Click 'Copy Level' two times and select the other colors. 

5. Click OK. 

Filtering the data: 

Data filtering helps to display the rows that satisfy the criteria subject to specification of a column. 

It is the easy way of finding the required data in a list. 

For Ex: To show the data out the marks who got between 60% and 70%, then data filtering helps 

to show the required data. 

There are two commands for filtering data in M.S.Excel, Viz. 



1. Auto Filters: It is used for filtering for simple criteria like the sorting of above 60% to 70% 

marks of students.It quickly filters a data set based on selection, specified text, number or 

other such criteria. 

 
2. Advanced Filter: Excel's Advanced Filter is really helpful when it comes to finding data that 

meets two or more complex criteria such as extracting matches and differences between 

two columns, filtering rows that match items in another list, finding exact matches 

including uppercase and lowercase characters, and more. For example, if the user wants 

to filter according to age, qualification, place and highest marks of students, then the user 

need to apply advanced filters. 

 
Custom Auto Filter:Excel Auto Filter supports filtering of data in number filter and text filter. 

The flowing are the steps to create a custom auto filter. 

 
2.1. Click any single cell inside a data set. 

2.2. On the Data tab, in the Sort & Filter group, click Filter. 

 
Arrows in the column headers appear 

Number Filter 

To apply a number filter, execute the following steps. 

2.3. Click the arrow next to selected column. 

2.4. Click Number Filters (this option is available because the Sales column contains 

numeric data) and select custom filter option from the list. 

2.5. Enter filter criteria in terms of mathematical operations greater than, less than 

etc and values from shows rows where block of custom auto filter dialog box and then 

click OK 
 
 



Text Filter: 

1. Click any single cell inside a data set. 

2. On the Data tab, in the Sort & Filter group, click Filter. Arrows in the column headers appear. 

 

 
Text Filter 

 

To apply a number filter, execute the following steps. 

3. Click the arrow next to selected column. 

4. Click Text Filters (this option is available because the Last Name column contains text data) and 

select Equals from the list. 

 
5. Enter filter criteria in terms equal, does not-equal, begins with, contains etcand values for that 

criteria from “shows rows where” block of custom auto filter dialog box and then click OK. 

 

 

 
We can also display records that begin with a specific character, end with a specific character, 

contain or do not contain a specific character, etc.We can use make use of meta characters like: 

?to represent single character in criteria 

* torepresent a series of zero or more characters in criteria.. Ex: ―?a*‖ 

To apply regular filter (Basic Filter) on data follow the given steps: STEPS: 

1. The data should include header row 

2. Data Menu – Sort & Filter Ribbon – Filter 

3. A drop-down arrow  will appear in the header cell for each column. 

4. Click the drop-down arrow for the column the user wants to filter. In our example, we will 

filter column B to view only certain types of data. 



 
 

5. The Filter menu will appear. 

6. Uncheck the box next to Select All to quickly deselect all data. 

7. Check the boxes next to the data to filter, then click OK. In this example, it get displayed 

Laptop and Tablet to view only those types of equipment. 

 

8. The data will be filtered, temporarily hiding any content that doesn't match the criteria. 

9. Filtering options can also be accessed from the Sort & Filter command on the Home tab. 
 

To clear a filter: 

After applying a filter, to remove—or clear—it from the worksheet: 

9.1. Click the drop-down arrow for the filter to clear. 

9.2. The Filter menu will appear. 

9.3. Choose Clear Filter from [COLUMN NAME] from the Filter menu. 

9.4. The filter will be cleared from the column. The previously hidden data will be displayed. 

9.5. To remove all filters from your worksheet, click the Filter 

command on the Data tab. 

 

Advanced filtering: 

If the user need to filter for something specific, basic filtering may not give enough options.   

Excel includes many advanced filtering tools, including search, text, date, and number 

filtering, which can narrow the results to help find exactly.Advanced text filters can be used to 

display more specific information, such as cells that contain a certain number of characters, or 

data that excludes a specific word or number. 

 

Extracting a Unique list: You can use Excel Advanced Filter to quickly extract unique records 

from a data set (or in other words remove duplicates).Let‘s see 



how to use advanced filter to get a unique list.Suppose you have a dataset as shown below: 

 

As you can see, there are duplicate records in this data set (highlighted in orange). These could be 

due to an error in data entry or result of data compilation.In such a case, you can use Excel 

Advanced Filter tool to quickly get a list of all the unique records in a different location (so that 

your original data remains intact).Here are the steps to get all the unique records: 

 Select the entire data set (including the headers). 

 Go Data tab –> Sort & Filter –> Advanced. This will open the Advanced Filter dialog box. 

 
In the Advanced Filter dialog box, use the following details: 

 Action: Select the ‘Copy to another location’ option. This will allow you to specify the location 

where you can get the list of unique records. 

 List Range: Make sure it refers to the dataset from which you want to find unique records. Also, 

make sure headers in the data set are included. 

 Criteria Range: Leave this empty. 

 Copy To: Specify the cell address where you want to get the list of unique  

records. 

 Copy Unique Records Only: Check this option. 

 Click OK. 

 
This will instantly give you a list of all the unique records. 

 

Using Criteria in Excel Advanced Filter 
Getting unique records is one of the many things you can do with Excel advanced filter.Its primary 

utility lies in its ability to allow using complex criteria for filtering data.Here is what I mean by 

complex criteria. Suppose you have a dataset as shown below and you want to quickly get all the 

records where the sales are greater than 5000 and the region is the US. 

 

 

Here is how you can use Excel Advanced Filter to filter the records based on the specified criteria: 



 The first step when using Excel Advanced Filter with complex criteria is to specify the criteria. To 

do this, copy the headers and paste it somewhere in the worksheet. 

 Specify the criteria for which you want to filter the data. In this example, since we want to get all 

the records for the US with sales more than 5000, enter ‘US’ in the cell below Region and >5000 

in the cell below Sales. This would now be used as an input in Advanced Filter to get the filtered 

data (as shown in the next steps). 

 
 Select the entire data set (including the headers). 

 Go Data tab –> Sort & Filter –> Advanced. This will open the Advanced Filter dialog box. In the 

Advanced Filter dialog box, use the following details: 

 Action: Select the ‘Copy to another location’ option. This will allow you to specify the location 

where you can get the list of unique records. 

List Range: Make sure it refers to the dataset from which you want to find unique records. Also, 

make sure headers in the data set are included. 

 Criteria Range: Specify the criteria we constructed in the steps above. In this example, it would be 

F1:I3. 

 Copy To: Specify the cell address where you want to get the list of unique records. 

 Copy Unique Records Only: Check this option. 

 Click OK. 

 
This would instantly give you all the records where the region is the US and the sales are more than 

5000. 

 

Pivot Table - The ability to create a brand new table based on existing data for the purpose of 

viewing, reporting and analyzing data. 

 

A Pivot Table is a summary of a large dataset that usually includes the total figures, average, 

minimum, maximum, etc. let's say you have a sales data for different regions, with a pivot table, 

you can summarize the data by region and find the average sales per region, the maximum and 

minimum sale per region, etc. Pivot tables allow us to analyze, summarize and show only 

relevant data in our reports. 
 

In other words, pivot tables extract meaning from that seemingly endless jumble of numbers on 

your screen. And more specifically, it lets you group your data together in different ways so you 

can draw helpful conclusions more easily. 



Creating a pivot table: 

Specifying PivotTable Data Before creating a PivotTable you must know what you want to 

analyze. There are three questions you have to ask before proceeding: 

 What do you want your column headers to be? 

 What do you want your row headers to be? 

 What data do you want to analyze? 

By understanding the layout, you will have a better perspective on how to create a PivotTable. 

 
Ex: Our data set consists of 213 records and 6 fields. Order ID, Product, Category, Amount, 

Date and Country. 

 
Insert a Pivot Table 

To insert a pivot table, execute the following steps. 

1. Click any single cell inside the data set. 

2. On the Insert tab, in the Tables group, click PivotTable. 

The following dialog box appears. Excel automatically selects the data for you. The default 

location for a new pivot table is New Worksheet. 

3. Click OK. 
 

Drag fields 

The PivotTable Fields pane appears. To get the total amount exported of each product, drag the 

following fields to the different areas. 

1. Product field to the Rows area. 

2. Amount field to the Values area. 

3. Country field to the Filters area. 

As a result, Bananas are our main export product. That's how easy pivot tables can be! 



Sort 

To get Banana at the top of the list, sort the pivot table. 

1. Click any cell inside the Sum of Amount column. 

2. Right click and click on Sort, Sort Largest to Smallest. 

 

Filter 

Because we added the Country field to the Filters area, we can filter this pivot table by 

Country. For example, which products do we export the most to France? 

1. Click the filter drop-down and select France. Result. Apples are our main export product to 

France. 

Note: you can use the standard filter (triangle next to Row Labels) to only show the amounts of 

specific products. 

 

Change Summary Calculation 

By default, Excel summarizes your data by either summing or counting the items. To change the 

type of calculation that you want to use, execute the following steps. 

1. Click any cell inside the Sum of Amount column. 

2. Right click and click on Value Field Settings. 

 

 
 

3. Choose the type of calculation you want to use. For example, click Count. 

4. Click OK. 

Pivot charts: 

After creating a pivot table in Excel 2016, you can create a pivot chart to display its summary 

values graphically. 

Sometimes it's hard to see the big picture when your raw data hasn‘t been summarized. Your 

first instinct may be to create a PivotTable, but not everyone can look at numbers in a table and 

quickly see what's going on. PivotCharts are a great way to add data visualizations to your data. 



Create a PivotChart 

 
1. Select a cell in your table. 

2. Select Insert > PivotChart . 

3. Select OK. 

 

Create a chart from a PivotTable 

 
1. Select a cell in your table. 

2. Select PivotTable Tools > Analyze > PivotChart . 

3. Select a chart. 

4. Select OK. 

 
Filter Pivot Chart 

To filter this pivot chart, execute the following steps. 

1. Use the standard filters (triangles next to Product and Country). For example, use the 

Country filter to only show the total amount of each product exported to the United States. 

2. Remove the Country filter. 
3. Because we added the Category field to the Filters area, we can filter this pivot chart (and pivot 

table) by Category. For example, use the Category filter to only show the vegetables exported 
to each country. 

 

Change Pivot Chart Type 

You can change to a different type of pivot chart at any time. 

1. Select the chart. 

2. On the Design tab, in the Type group, click Change Chart Type. 

3. Choose Pie. 

4. Click OK. 
 

Excel gives you the ability to protect your work, whether it‘s to prevent someone from opening a 

workbook without a password, granting Read-Only access to a workbook, or even just protecting a 

worksheet so you don‘t inadvertently delete any formulas. 

 
Workbook-level: To control how users should work with worksheets inside your workbook‘s 

structure, use workbook-level protection. You can lock the structure of your workbook by 

specifying a password. Locking the workbook structure prevents other users from adding, moving, 

deleting, hiding, and renaming worksheets. 

 To prevent other users from viewing hidden worksheets, adding, moving, deleting, or hiding 

worksheets, and renaming worksheets, you can protect the structure of your Excel workbook 

with a password. 



 If you protect the workbook structure, users cannot insert, delete, rename, move, copy, 

hide or unhide worksheets anymore. 

1. Open a workbook. 

2. On the Review tab, in the Changes group, click Protect Workbook. Or click on file menu > 

info>protect workbook. 

3. Check Structure, enter a password and click OK. 

4. Reenter the password and click on OK. 

5. Users cannot insert, delete, rename, move, copy, hide or unhide worksheets anymore. 

If you forget or lose your password, you can’t retrieve it. 

 
Worksheet-level: To control how users should work within an individual worksheet, use 

worksheet-level protection. With sheet protection, you can control how a user can work within 

worksheets. You can specify what exactly a user can do within a sheet, thereby making sure 

that none of the important data in your worksheet are affected. For example, you might want a 

user to only add rows and columns, or only sort and use AutoFilter. Once sheet protection is 

enabled, you can protect other elements such as cells, ranges, formulas, and ActiveX or Form 

controls. 

 To protect a sheet in Excel perform the following steps. 

 To password protect your Excel sheet, type a password in the corresponding field. Be sure to 

remember the password or store it in a safe location because you will need it later to 

unprotect the sheet. 

 Right click a worksheet tab at the bottom of your screen and select Protect Sheet… from 

the context menu.Or, click the Protect Sheet button on the Review tab, in the Changes 

group. 

 In the Protect Sheet dialog window, do the following: 

 Select the actions you allow the users to perform. 

o By default, the following 2 options are selected: Select locked cells and Select 

unlocked cells. If you leave only these two options selected, the users of your 

sheet, including yourself, will be able only to select cells (both locked and 

unlocked). 

o To allow some other actions such as sorting, filtering, formatting cells, deleting or 

inserting rows and columns, check the corresponding boxes. 

o If you don't check any action, users will only be able to view the contents of your 

Excel sheet. 

 Click the OK button. 

 To unprotect a worksheet, Right-click the sheet tab, and select Unprotect Sheet… 

from the context menu. 

Sharing a workbook: 

These days more and more people are using Microsoft Excel for team work. We can also 

export and share workbooks with others directly from Excel. The recent versions of Excel 2010, 

2013 and 2016 make it easy to share and collaborate on workbooks. By sharing an Excel file, you 

are giving other users access to the same document and allow them to make edits simultaneously. 

Here we will learn how to share an Excel workbook for multiple users by saving it to a local 

network location 



where other people can access it and make edits. You can keep track of those changes and accept 

or reject them. 

With the workbook open, perform the following steps to share it: 

1. On the Review tab, in the Changes group, click the Share Workbook button. 
 

 
 

 

2. The Share Workbook dialog box will appear, and you select the Allow changes by more 
than one user at the same time. This also allows workbook merging check box on the 
Editing tab. 
3. Optionally, switch to the Advanced tab, select the desired settings for tracking changes, 

and click OK. 

For example, you may want to have changes updated automatically every n number of 

minutes (all the other settings on the screenshot below are the default ones). 

4. Save you Excel file to a network location where other people can access it (the fastest 

way is by using the Ctrl + S shortcut). 

5. If done correctly, the word [Shared] will appear to the right of the workbook's name 

6. When the teamwork has been completed, you can stop sharing the workbook in this way: 

Open the Share Workbook dialog box (Review tab > Changes group). On the Editing tab, clear the 

Allow changes by more than one user at the same time… check box, and click OK. 

 

Track Changes in workbook: 

When collaborating on an Excel workbook, you may want to keep track of the changes that have 

been made to it. This could be especially useful when the document is almost finished and your 

team is making the final revisions. In an Excel file, you can review, accept or reject changes 

electronically by using the Track Changes feature specially designed for it. By using the built-in 

Track Changes in Excel, you can easily review your edits directly in the edited worksheet or on a 

separate sheet, and then accept or reject each change individually or all changes at a time. To use 

the Excel tracking feature most effectively, there are a few points for you to remember. 

1. Track Changes is only available in shared workbooks 

2. Track Changes cannot be used in workbooks that contain tables 

3. It's not possible to undo changes in Excel 

4. Not all changes are tracked in Excel 

5. Change history is kept for 30 days by default 



Turn on Excel Track Changes feature 

To view the changes made to a given workbook by you or other users, perform these steps: 

1. Be certain that you want to use this method before continuing. Shared Workbooks have 

limitations, and therefore we highly recommend co-authoring, which is the replacement 

for Shared Workbooks. 

2. Click Review > Share Workbook. 

Note that in newer versions of Excel, the Share Workbook button has been hidden. Here's 

how to unhide it. 

3. In the Share Workbook dialog box, on the Editing tab, select the Allow changes by more 

than one user at the same time check box. 

4. Click the Advanced tab. 

5. Under Track changes, click Keep change history for and, in the days box, type the 

number of days of change history that you want to keep. By default, Excel keeps the 

change history for 30 days and permanently erases any change history that is older than 

this number of days. To keep change history for a longer than 30 days, enter a number 

that is larger than 30. 

6. Click OK and, if you are prompted to save the workbook, click OK to save the workbook. 

 

Charts in Excel: 

A chart is a tool you can use in Excel to communicate data graphically. Charts allow your audience 

to see the meaning behind the numbers, and they make showing comparisons and trends much 

easier. A chart is a visual representation of data, in which the data is represented by symbols such 

as bars in a bar chart or lines in a line chart. 

 
Chart Elements 

The different parts that make up a chart are referred to as chart elements. Chart elements give more 

descriptions to your charts, thus making your data more meaningful and visually appealing. 

Follow the steps given below to insert the chart elements in your graph. 

Step 1 − Click the chart. Three buttons appear at the upper-right corner of the chart. 

Step 2 − Click the Chart Elements icon. A list of available elements will be displayed. 

 

The following chart elements are available − 
 

Excel charts have a handful of elements. Some of these elements are displayed by default, others 

can be added and modified manually as needed. 

1. Chart area 

2. Chart title 

3. Plot area 

4. Horizontal (category) 
axis 

5. Vertical (value) axis 

6. Axis title 

7. Data points of the data series 

8. Chart legend 

9. Data label 



 
 

 Chart Area: The chart area is everything within the outside border. This is the area that 

makes up the chart. All charts have a chart area. This includes the plot area and the space 

outside it. You need to select the chart area when you want to make changes to the whole 

chart 

 Chart titles: When you create a chart, a Chart Title box appears above the chart. 

 Plot Area: The plot area is the area which is enclosed by the two axis. This area can have its 

own border as well as a background color. The plot area is everything enclosed by the axes.

This does not include titles, legend, etc. This is the area 

enclosed by the two axes. All charts have a plot area. 

 
 Axes: Charts typically have two axes that are used to measure and categorize the data.A 

vertical axis (also known as value axis or y axis), andA horizontal axis (also known as 

category axis or x axis)3-D Column charts have a third axis, the depth axis. 

 Axis titles: Axis titles give the understanding of the data of what the chart is all about.You 

can add axis titles to any horizontal, vertical, or the depth axes in the chart.You cannot add 

axis titles to charts that do not have axes (Pie or Doughnut charts). 

 Data Series: A data series is a collection of data points (or markers) and normally corresponds 

to the data within a single row or column. This could be a series of columns, bars or a series 

of squares or crosses joined together by a line. 

 Data labels:Data labels make a chart easier to understand because they show the details 

about a data series or its individual data points. You can change the location of the data 

labels within the chart, to make them more readable. 

 Legend:When you create a chart, the Legend appears by default. You can hide a Legend by 

deselecting it from the Chart Elements list. 



Creating Charts with Insert Chart 
 

To create a chart in Excel, you start by entering the numeric data on a worksheet, and then 

continue with the following steps. 

 
1. Prepare the data to plot in a chart 

 

 You can organize the data in rows or columns, and Microsoft Excel will automatically 

determine the best way to plot the data in your graph 

 The data in the first column (or columns headings) is used as labels along the X axis of your 

chart. 

 The numerical data in other columns are used to create the labels for the Y axis. 

 Either the column headings or data in the first column are used in the chart legend. 

Excel automatically chooses the data for the legend based on your data layout. 

 
2. Select data to include in the chart 

 
 Select all the data you want to include in your Excel graph. Be sure to select the column 

headings if you want them to appear either in the chart legend or axis labels. 

3. Inset the chart in Excel worksheet 

 To add the graph on the current sheet, go to the Insert tab > Charts group, and click on a 

chart type you would like to create. 

 
To use the option Recommended Charts, follow the steps given below − 

Step 1 − Select the data. 

Step 2 − Click the Insert tab on the Ribbon. 

Step 3 − Click Recommended Charts. 

 

Formatting Charts in Excel 

Once you create a chart it's easy to format and enhance your chart using Excel's menus and 

commands. To change chart style in Excel, simply right click or double click on the chart item 

you want to format to view the formatting options for that item. 

Just a few of the chart items you can format are: 

 Chart Titles, Axis Titles, and Data Labels 

 Chart Lines 

 Axis Labels 

 Plot Area / Chart Area 
 

Overall, there are 3 ways to customize charts in Excel 2016 and Excel 2013. 



1. Select the chart and look for the needed options on the Chart Tools tabs on the Excel ribbon. 

 

2. Right-click an element on the chart and select the corresponding context menu item. For 

example, here's the right-click menu for customizing the chart title: 

 

3. Use on-object chart customization buttons. These buttons appear in the top right corner of 

your chart as soon as you click on it. 
 

 

 Chart Elements button. It launches the checklist of all the elements you can modify or 

add to your graph, and it only shows those elements that are applicable to the selected chart 

type. The Chart Elements button supports Live Preview, so if you are not sure what a certain 

element is, hover the mouse on it and you will see what your graph would look like if you 

select that option. 

 Chart Styles button. It lets you quickly change the chart styles and colors. 

 Chart Filters button. It allows you to show or hide data displayed in your chart. 

For more options, click the Chart Elements button, find the element you want to add or 

customize in the checklist, and click the arrow next to it. The Format Chart pane will appear 

on the right of your worksheet, where you can select the options you want: 



 

 

Format your chart using the Ribbon 

1. In your chart, click to select the chart element that you want to format. 

2. On the Format tab under Chart Tools, do one of the following: 

 Click Shape Fill to apply a different fill color, or a gradient, picture, or texture to the 

chart element. 

 

 Click Shape Outline to change the color, weight, or style of the chart element. 

 Click Shape Effects to apply special visual effects to the chart element, such as shadows, 

bevels, or 3-D rotation 

 

3. To apply a predefined shape style, on the Format tab, in the Shape Styles group, click the 

style that you want. To see all available shape styles, click the More button 

4. To change the format of chart text, select the text, and then choose an option on the mini 

toolbar that appears. Or, on the Home tab, in the Font group, select the formatting that you 

want to use. 

 
Types of Charts: 

Excel provides you different types of charts that suit your purpose. Based on the type of data, 

you can create a chart. You can also change the chart type later. 

Excel offers the following major chart types − 

 
 Column Chart 

 Bar Chart 

 Pie Chart 

 Doughnut Chart 

 Line Chart 

 Area Chart 

 XY (Scatter) Chart 

 Bubble Chart 

 Stock Chart 



 Surface Chart 

 Radar Chart 

Column Chart 

A Column Chart typically displays the categories along the horizontal (category) axis and values 

along the vertical (value) axis. To create a column chart, arrange the data in columns or rows on 

the worksheet. 

A column chart looks as follows − 

 

Line Chart 

Line charts can show continuous data over time on an evenly scaled Axis. Therefore, they are 

ideal for showing trends in data at equal intervals, such as months, quarters or years. 

In a Line chart − 

 Category data is distributed evenly along the horizontal axis. 

 Value data is distributed evenly along the vertical axis. 

To create a Line chart, arrange the data in columns or rows on the worksheet. A line chart looks 

as follows: 
 

 
 

Pie Chart 

Pie charts show the size of items in one data series, proportional to the sum of the items. The data 

points in a pie chart are shown as a percentage of the whole pie. To create a Pie Chart, arrange the 

data in one column or row on the worksheet. 

A Pie Chart has the following sub-types − 

 Pie 

 3-D Pie 



 Pie of Pie 

 Bar of Pie 

 

Doughnut Chart 

A Doughnut chart shows the relationship of parts to a whole. It is similar to a Pie Chart with the 

only difference that a Doughnut Chart can contain more than one data series, whereas, a Pie Chart 

can contain only one data series. 

A Doughnut Chart contains rings and each ring representing one data series. To create a 

Doughnut Chart, arrange the data in columns or rows on a worksheet. 

 

Bar Chart 

Bar Charts illustrate comparisons among individual items. In a Bar Chart, the categories are 

organized along the vertical axis and the values are organized along the horizontal axis. To create 

a Bar Chart, arrange the data in columns or rows on the Worksheet. 

A Bar Chart has the following sub-types − 

 Clustered Bar, Stacked Bar, 100% Stacked Bar, 3-D Clustered Bar, 3-D Stacked Bar, 3- D 

100% Stacked Bar etc. 



 

 

Area Chart 

Area Charts can be used to plot the change over time and draw attention to the total value across 

a trend. By showing the sum of the plotted values, an area chart also shows the relationship of 

parts to a whole. To create an Area Chart, arrange the data in columns or rows on the worksheet. 

 

 
XY (Scatter) Chart 

XY (Scatter) charts are typically used for showing and comparing numeric values, like scientific, 

statistical, and engineering data. 

A Scatter chart has two Value Axes − 

 Horizontal (x) Value Axis 

 Vertical (y) Value Axis 

It combines x and y values into single data points and displays them in irregular intervals, or 

clusters. To create a Scatter chart, arrange the data in columns and rows on the worksheet. Place 

the x values in one row or column, and then enter the corresponding y values in the adjacent rows 

or columns. 

Consider using a Scatter chart when − 

 You want to change the scale of the horizontal axis. 

 You want to make that axis a logarithmic scale. 

 Values for horizontal axis are not evenly spaced. 

 There are many data points on the horizontal axis. 



 You want to adjust the independent axis scales of a scatter chart to reveal more 

information about data that includes pairs or grouped sets of values. 

 You want to show similarities between large sets of data instead of differences 

between data points. 

 You want to compare many data points regardless of the time. 

o The more data that you include in a scatter chart, the better the comparisons you can 

make. 

 
Bubble Chart 

A Bubble chart is like a Scatter chart with an additional third column to specify the size of the 

bubbles it shows to represent the data points in the data series. 

A Bubble chart has the following sub-types − 

 Bubble 

 Bubble with 3-D effect 
 

 

 

 

 
 

 

Surface Chart 

A Surface chart is useful when you want to find the optimum combinations between two sets of 

data. As in a topographic map, colors and patterns indicate areas that are in the same range of 

values. 



To create a Surface chart − 

 Ensure that both the categories and the data series are numeric values. 

 Arrange the data in columns or rows on the worksheet. A Surface chart has the following 

sub-types − 

 3-D Surface 

 Wireframe 3-D Surface 

 Contour 

 Wireframe Contour 

 

Radar Chart 

Radar charts compare the aggregate values of several data series. To create a Radar chart, arrange 

the data in columns or rows on the worksheet. 

r 

Combo Chart 

Combo charts combine two or more chart types to make the data easy to understand, especially 

when the data is widely varied. It is shown with a secondary axis and is even easier to read. To 

create a Combo chart, arrange the data in columns and rows on the worksheet. 



 

 

Using Templates in Excel: 

A template is a predesigned spreadsheet you can use to create new spreadsheets with the same 

formatting and predefined formulas. With templates, you don't need to know how to do the math, 

or even how to write formulas—these are already integrated into the spreadsheet. 

How to create a chart template 

 In Excel 2013 and 2016, to save a graph as a chart template, right-click the chart and pick 

Save as Template in the pop-up menu: 

 Clicking the Save As Template option brings up the Save Chart Template dialog, where 

you type the template name and click the Save button. 

 By default, the newly created chart template is saved to the special Charts folder. All 

chart templates stored to this folder are automatically added to the Templates folder that 

appears in the Insert Chart and Change Chart Type dialogs when you create a new or 

modify an existing graph in Excel. 

How to apply the chart template 

 To create a chart in Excel based on a specific chart template, open the Insert Chart 

dialog by clicking the Dialog Box Launcher in the Charts group on the ribbon. On the All 

Charts tab, switch to the Templates folder, and click on the template you want to apply. 

 To apply the chart template to an existing graph, right click on the graph and choose 

Change Chart Type from the context menu. Or, go to the Design tab and click Change 

Chart Type in the Type group. 

 Either way, the Change Chart Type dialog will open, you find the desired template in the 

Templates folder and click on it. 

How to delete a chart template in Excel 

 To delete a graph template, open the Insert Chart dialog, go to the Templates folder and 

click the Manage Templates button in the bottom left corner. 

 

 
 
 
 
 
 
 
 
 
 
 



Data Outline: Outlining Data 

Outlining data makes your data easier to view. Outline includes grouping, ungrouping & 

subtotal. With the help of outline data options the user can hide and unhide for temporary purpose 

and also to calculate automatic mathematical options with the help of subtotal. 

 

Grouping the data: 

 
With the help of grouping the data, the user can group the selected columns and rows. 

 

STEPS: 
 

 
SUBTOTAL 

 
1. First, sort the data on the Company column. 

 
2. On the Data tab, in the Outline group, click Subtotal. 

3. Select the Company column, the column we use to outline our worksheet. 

4. Use the Count function. 

5. Check the Company check box. 

6. Click OK. 

Result: 



 

7. To collapse a group of cells, click a minus sign. You can use the numbers to collapse or 

expand groups by level. For example, click the 2 to only show the subtotals. 

 

Note: click the 1 to only show the Grand Count, click the 3 to show everything. To collapse a 

group of columns, execute the following steps. 

8. For example, select column A and B. 

9. On the Data tab, in the Outline group, click Group. 

10. Click the minus sign above column C (it will change to a plus sign). Result: 

 

11. To remove the outline, click any cell inside the data set and on the Data tab, in the 

Outline group, click Subtotal, Remove all. 



 

 

OUTLINE THE GROUP 

 
Outline (group) data in a worksheet: 

 
If you have a list of data that you want to group and summarize, you can create an outline of up to 

eight levels, one for each group. Each inner level, represented by a higher number in the outline 

symbols, displays detail data for the preceding outer level, represented by a lower number in the 

outline symbols. Use an outline to quickly display summary rows or columns, or to reveal the 

detail data for each group. You can create an outline of rows (as shown in the example below), an 

outline of columns, or an outline of both rows and columns. 

 

An outlined row of sales data grouped by geographical 

regions and months with several summary and detail 

rows displayed. 

4. Level 3 contains detail rows — in 

this case, rows 11 through 13. 

 

5. To expand or collapse data in your 

outline, click the   and   outline 

symbols. 
 

 

1. To display rows for a level, click 

the appropriate outline 

symbols. 

 

2. Level 1 contains the total sales 

for all detail rows. 

 

3. Level 2 contains total sales for 

each month in each region. 



Create an outline of rows 
 

1. Make sure that each column of the data that you want to outline has a label in the first row, 

contains similar facts in each column, and that the range has no blank rows or columns. 

2. Make sure your detail rows also have a summary row—a subtotal. Do one of the following: 
 

Insert summary rows by using the Subtotal command 

 
o Use the Subtotal command, which inserts the SUBTOTAL function immediately below or above 

each group of detail rows and automatically creates the outline for you. For more information 

about using the Subtotal function, see SUBTOTAL function. 

 

Insert your own summary rows 

 
o Insert your own summary rows, with formulas, immediately below or above each group of detail 

rows. For example, under (or above) the rows of sales data for March and April, use the SUM 

function to subtotal the sales for those months. The table later in this topic shows you an 

example of this. 

3. Specify whether the summary rows are located below or above the detail rows. On the Data tab, 

in the Outline group, click the Outline dialog box launcher. 

 

4. If your summary rows are above your detail rows, clear the Summary rows below detail 

checkbox. Otherwise, leave the checkbox alone. 

5. Outline your data. Do one of the following: 
 

 
 

Outline the data automatically 

 
a. If necessary, select a cell in the range of cells you want to outline. 

b. On the Data tab, in the Outline group, click the arrow under Group, and then click Auto 

Outline. 

c. Outline the outer group. 
 



Outline the data manually 
 
 

 If you want to ungroup rows/columns, select the rows/columns, and then on the 

Data tab, in the Outline group, click Ungroup. 

 You can also ungroup sections of the outline without removing the entire outline. Hold 

down SHIFT while you click the     or     for the group, and then on the Data tab, in the 

Outline group, click Ungroup. 

 

 
 

Create an outline of columns 

 
1. Make sure that each row of the data that you want to outline has a label in the first column, 

contains similar facts in each row, and the range has no blank rows or columns. 

2. Insert your own summary columns with formulas immediately to the right or left of each group 

of detail columns. The table listed in step 4 below shows you an example. 

 
 

3. Specify whether the location of the summary column is to the right or left of the detail columns. 

On the Data tab, in the Outline group, click the Outline dialog box launcher. 

 

How to specify the summary column location 

 
a. On the Data tab, in the Outline group, click the Outline dialog box launcher. 

 



b. To specify a summary column to the left of the details column, clear the Summary columns to 

right of detail check box. To specify a summary column to the right of the details column, select 

the Summary columns to right of detail check box. 

c. Click OK. 

4. To outline the data, do one of the following: 

 

Outline the data automatically 

 
a. If necessary, select a cell in the range. 

b. On the Data tab, in the Outline group, click the arrow below Group and click Auto Outline. 

 

Outline the data manually 
 
 

c. Outline the outer group. 

 
How to outline the outer group (all the columns except the grand total) 

 
i. Select all of the subordinate summary columns, as well as their related detail data. 

 
In the example below, column E contains the subtotals for columns B through D, and column I 

contains the subtotals for columns F through H, and column J contains the grand totals. To group 

all of the detail data for column J, select columns B through I. 
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2,276 

 

Important: Do not include the summary column J (the grand totals) in the selection. 

 
ii. On the Data tab, in the Outline group, click Group. 

 
The outline symbols appear beside the group on the screen. 

 
d. Optionally, outline an inner, nested group (individual groups of detail columns). 

 

How to outline the inner, nested group (Groups of detail columns) 



3 West 192 185 143 520 773 419 365 1,557 2,077 

i. For each inner, nested group, select the detail columns adjacent to the column that contains the 

summary column. 

 

In the example below, to group columns B through D, which has a summary column E, select 

columns B through D. To group columns F through H, which has a summary row I, select 

columns F through H. 

A B C D E F G H I J 

1
 Reg
n 

Ja
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M
ar 

Q1 A
pr 
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Q2 H1 

2 East 371 504 880 1,755 186 653 229 1,068 2,823 

4 North 447 469 429 1,345 579 180 367 1,126 2,471 

 
 

Important: Do not include the summary column for that group in the selection. 

 
ii. On the Data tab, in the Outline group, click Group. 

 
The outline symbols appear beside the group on the screen. 

 
5. Continue selecting and grouping inner columns until you have created all of the levels that you 

want in the outline. 

6. If you want to ungroup columns, select the columns, and then on the Data tab, in the Outline 

group, click Ungroup. 

 

 
Show or hide outlined data 

 

1. If you don't see the outline symbols , , and , click the Microsoft Office Button   

and then click Excel Options (Excel 2007), OR, click the File tab (other 

versions), and then click Options, click the Advanced category, and then under the Display 

options for this worksheet section, select the worksheet, and then select the Show outline 

symbols if an outline is applied check box. 

2. Click OK. 

3. Do one or more of the following: 

 

Show or hide the detail data for a group 

 
o To display the detail data within a group, click the   for the group. 

o To hide the detail data for a group, click the     for the group. 

5 South 281 511 410 1,202 124 750 200 1,074 2,276 



Expand or collapse the entire outline to a particular level 

 
o In the   outline symbols, click the number of the level that you want. Detail data at lower 

levels is then hidden. 

 

For example, if an outline has four levels, you can hide the fourth level while displaying the rest of 

the levels by clicking     . 

 

Show or hide all of the outlined detail data 

 
o To show all detail data, click the lowest level in the   outline symbols. For example, if there 

are three levels, click     . 

o To hide all detail data, click   . 
 

 
Customize an outline with styles 

 
For outlined rows, Microsoft Excel uses styles such as RowLevel_1 and RowLevel_2 . For 

outlined columns, Excel uses styles such as ColLevel_1 and ColLevel_2. These styles use bold, 

italic, and other text formats to differentiate the summary rows or columns in your data. By 

changing the way each of these styles is defined, you can apply different text and cell formats to 

customize the appearance of your outline. You can apply a style to an outline either when you 

create the outline or after you create it. 

 

Do one or more of the following: 

 

Automatically apply a style to a summary row or column 

 
1. On the Data tab, in the Outline group, click the Outline dialog box launcher. 

 

 

2. Select the Automatic styles check box. 

 

Apply a style to an existing summary row or column 

 
1. Select the cells that you want to apply outline styles to. 

2. On the Data tab, in the Outline group, click the Outline dialog box launcher. 



 
 

3. Select the Automatic styles check box. 

4. Click Apply Styles. 

 

Hide or remove an outline 

 
Note: No data is deleted when you hide or remove an outline. 

 

Remove an outline 

 
1. Click the worksheet. 

2. One the Data tab, in the Outline group, click Ungroup and click Clear Outline. Data Validation: 

 

What is data validation in Excel? 

Data Validation is a very useful and easy to use tool in Excel with which you can set data 

validations on the data that is entered that is entered into your Worksheet. Excel Data Validation 

is a feature that restricts (validates) user input to a worksheet. Technically, you create a validation 

rule that controls what kind of data can be entered into a certain cell. In Excel, the data validation 

feature helps you control what can be entered in your worksheet. For example, you can: 

 Allow only numeric or text values in a cell. 

 Allow only numbers within a specified range. 

 Allow data entries of a specific 

 Restrict dates and times outside a given time frame. 

 Restrict entries to a selection from a drop-down list. 

 Validate an entry based on another cell. 

 Show an input message when the user selects a cell. 

 Show a warning message when incorrect data has been entered 



 

 

How to do data validation in Excel 
 

To add data validation in Excel, perform the following steps. 

 
1. Open the Data Validation dialog box 

Select one or more cells to validate, go to the Data tab > Data Tools group, and click the Data 

Validation button. 

You can also open the Data Validation dialog box by pressing Alt > D >L, with each key pressed 

separately. 

 
2. Create an Excel validation rule 

On the Settings tab, define the validation criteria according to your needs. In the criteria, you can 

supply any of the following: 

 Values - type numbers in the criteria boxes like shown in the screenshot below. 

 Cell references - make a rule based on a value or formula in another cell. 

 Formulas - allow to express more complex conditions like in this example. 

As an example, let's make a rule that restricts users to entering a whole number between 1000 and 

9999: 



With the validation rule configured, either click OK to close the Data Validation window or 

switch to another tab to add an input message or/and error alert. 

 
3. Add an input message (optional) 

If you want to display a message that explains to the user what data is allowed in a given cell, open 

the Input Message tab and do the following: 

 Make sure the Show input message when cell is selected box is checked. 

 Enter the title and text of your message into the corresponding fields. 

 Click OK to close the dialog window. 

 
 

4. Display an error alert (optional) 

In addition to the input message, you can show one of the following error alerts when invalid data 

is entered in a cell. 

 Alert in stop box 

 Alert Warning box 

 Alert in Information box 

To configure a custom error message, go to the Error Alert tab and define the following 

parameters: 

 Check the Show error alert after invalid data is entered box (usually selected by default). 

 In the Style box, select the desired alert type. 

 Enter the title and text of the error message into the corresponding boxes. 

 Click OK. 

 

Date and time validation in Excel 



To validate dates, select Date in the Allow box, and then pick an appropriate criteria in the 

Databox. There are quite a lot of predefined options to choose from: allow only dates between two 

dates, equal to, greater than or less than a specific date, and more. 

Similarly, to validate times, select Time in the Allow box, and then define the required criteria. 

For example, to allow only dates between Start date in B1 and End date in B2, apply this Excel 

date validation rule: 

 
To validate entries based on today's date and current time, make your own data validation like: 

Validate dates based on today's date: In many situations, you may want to use today's date as 

the start date of the allowed date range. To get the current date, use The TODAY function, and 

then add the desired number of days to it to compute the end date. 

For example, to limit the data entry to 6 days from now (7 days including today), we are going to 

use the built-in Date rule with the formula-based criteria: 

 Select Date in the Allow 

 Select between in the Data 

 In the Start date box, enter =TODAY() 

 In the End date box, enter =TODAY() + 6 

Validate times based on current time: To validate data based on the current time, use the 

predefined Time rule with your own data validation formula: 

 In the Allow box, select Time. 

 In the Data box, pick either less than to allow only times before the current time, or 

greater than to allow times after the current time. 



 In the End time or Start time box (depending on which criteria you selected on the 

previous step), enter one of the following formulas: 

 To validate dates and times based on the current date and time: 

=NOW() 
 

 To validate times based on the current time: 

=TIME( HOUR(NOW()), MINUTE(NOW()), SECOND(NOW())) 

 

Text length 
 

To allow data entry of a specific length, select Text length in the Allow box, and choose the 

validation criteria in accordance with your business logic. 

For example, to limit the input to 10 characters, create this rule: 
 

 

Excel data validation list (drop-down) 
 

To add a drop-down list of items to a cell or a group of cells, select the target cells and do the 

following: 

1. Open the Data Validation dialog box (Data tab > Data Validation). 

2. On the Settings tab, select List in the Allow 

3. In the Source box, type the items of your Excel validation list, separated by commas. For 

example, to limit the user input to three choices, type Yes, No, N/A. 

4. Make sure the In-cell dropdown box is selected in order for the drop-down arrow to appear 

next to the cell. 

5. Click OK. 



 
 
 

Note. Please be careful with the Ignore blank option, which is selected by default. If you are 

creating a drop-down list based on a named range that has at least one blank cell, selecting this 

check box allows entering any value in the validated cell. In many situations, it is also true for 

validation formulas: if a cell referenced in the formula is blank, any value will be allowed in the 

validated cell. 

 
How to remove data validation in Excel 

 

The standard approach designed by Microsoft and the mouse-free technique devised by Excel 

geeks who would never take their hands off the keyboard unless absolutely necessary (e.g. to take 

a cup of coffee :) 

 

Method : Regular way to remove data validation 
 

Normally, to remove data validation in Excel worksheets, you proceed with these steps: 

1. Select the cell(s) with data validation. 

2. On the Data tab, click the Data Validation button. 

3. On the Settings tab, click the Clear All button, and then click OK. 
 



Data Consolidation: 

Excel 2016 allows you to consolidate data from different worksheets into a single worksheet. 

Using the program‘s Consolidate command button on the Data tab of the Ribbon, you can easily 

combine data from multiple spreadsheets.The beauty of the Consolidate feature is that it can 

easily sum, count, average, etc. The ranges you consolidate do not have to be of the same size in 

each worksheet, the number of rows or columns might be different from sheet to sheet. And yet, 

you can still consolidate the data into a summary sheet. 

 
For example, you can use the Consolidate command to total all budget spreadsheets prepared by 

each department in the company or to create summary totals for income statements for a period of 

several years. When you consolidate data in one worksheet, you can easily update and combine it. 

However, even when the data entries are laid out differently in each spreadsheet, Excel can still 

consolidate them provided that you‘ve used the same labels to describe the data entries in their 

respective worksheets. 

 

Consolidate data in multiple worksheets within the same workbook 

In our example, we have data for 3 years expenditure on tea, coffee and milk. The data is broken 

down into quarters and stored in one year per worksheet in one workbook. We can create a 

‗Consolidated Summary‘ sheet which will show expenditure by year and quarter. It does not 

matter if the data has the same arrangement of columns and rows or not.   Excel will sort that out 

for you. 

 

Year 1 worksheet 

 

Year 2 worksheet 

Year 3 worksheet 

 



The following are the steps to Consolidate: 

Step1: To start using the Data Consolidation tool, you need to select an empty sheet in the 

workbook as your master worksheet or add a new one if necessary. In this example the worksheet 

is renamed ‗Consolidated Summary‘. 

Step2:Select the upper-left cell of the area where you want the consolidated data to appear. 

Step3: On the Ribbon, Choose Data > Consolidate to view the Consolidate dialog: 

Step4:In the Function box, click the summary function that you want Excel to use to consolidate 

the data. As you will see from the drop-down, there are 11 functions to choose from. For our data 

we want to add up the values so we‘ll set the Function to Sum. 

 

Step5: Click in the Reference area and select the first data range to consolidate – to do this you 

will need to click the Sheet tab i.e. ―Year 1‖ and then drag over the data (including row and 

column headings) and then click the Add button to add this first set of data to the consolidation 

dialog. 

Step6: Continue in the same way by clicking on the next sheet, highlighting the data, and clicking    

on    the Add button    until    all    your    data    and     worksheets     appear     in the References 

section of the dialog e.g. ―Year 2‖ and ―Year 3‖. 

 

Note: You can name your ranges before you start the Consolidation process. If you name each 

range then, when you create the consolidation, place your cursor in the Reference field, press F3 

and then choose the range from the list in the Paste Name dialog. 

Step7: To indicate where the labels are located in the source ranges, select the check boxes 

under Use labels in: either the Top row, the Left column, or both. In this example, Top 



row is the name of the quarters, i.e. Quarter 1, Quarter 2, etc. and the Left Column are the list of 

items, i.e. Coffee, Tea and Milk. 

Automatic vs. Manual updates: If you want Excel to update your consolidation table 

automatically when the source data changes, select the Create links to source data check box. If 

unchecked, you can still update the consolidation manually. 

Step8: When you click OK, Excel summarizes all the data into your new sheet as your master 

worksheet (Consolidated Summary). 

 

 

Consolidate data from multiple workbooks to one new workbook 

Step1: Make sure all the individual workbooks you wish to consolidate are currently open. Step2: 

Open a new, blank workbook as your master worksheet or add a new one if necessary. The 

worksheet is renamed as ―Consolidate Summary‖ and save this workbook with a name e.g. 

Summary.xlsx. 

Step3: Select the upper-left cell of the area where you want the consolidated data to appear. 

Step4: On the Ribbon, Choose Data > Consolidate to view the Consolidate dialog 

Step5: selecting data ranges from different workbooks instead of different worksheets. Step6: 

When you click OK, Excel summarizes all the data into your new master worksheet 

(Consolidated Summary). 



UNIT –V 

MS Access&MS Excel 

MS ACCESS: Data, Information, Databases, File, Record, Fields-Features, Advantages And Limitations of 
MS Access – Applications Of MS Access- Tables, Forms, Queries, Reports. 
MS EXCEL: Features of MS Excel, spreadsheet/worksheet, workbook, cell, cell pointer, cell address etc. , 
parts of MS Excel window, Saving , Opening and closing workbook,- insertion and deletion of worksheet, 
entering and editing data in worksheet, cell range, formatting, auto fill, formula and its advantages 

FEATURES OF MS ACCESS 
 

  Users can create tables, queries, forms and reports. 

  The original concept of Access was for end users to be able to "access" data from any source. It 

also has the ability to link to data in its existing location and use it for viewing, querying, 

editing, and reporting. This allows the existing data to change while ensuring that Access uses 

the latest data. 

  One of the benefits of Access from a programmer's perspective is its relative compatibility with 

SQL (structured query language) — queries can be viewed graphically or edited as SQL 

statements. 

  Microsoft Access offers parameterized queries. 

  Microsoft Access is a file server-based database. Unlike client–serverrelational database 

management systems (RDBMS), Microsoft Access does not implement database triggers, 

stored procedures, or transaction logging. 

  Microsoft Access can also import or link directly to data stored in other applications and 

databases like Excel, XML, Oracle etc. 

 
PARTS OF MS ACCESS WINDOW 

Title bar: This bar across the top of the program window displays the name of the active 

database and by default display the path to the folder where it is stored. It also provides tools 

for managing the program and the program window. 



 
 

  At the left end of the title bar is the program icon, which is used to display commands to restore, 

move, size, minimize, maximize, and close the program window. To the right of the Access 

icon is the Quick Access Toolbar. By default, the Quick Access Toolbar displays the Save, Undo, 

and Redo buttons, we can customize it to display any command we want. 

  Ribbon: Ribbon Below the title bar, all the commands for working with an Access database are 

represented as buttons in this central location so that you can work efficiently with the 

program. 

  Navigation pane: Navigation pane,on the left side of the program window displays lists of 

database objects. By default, it displays all the objects in the database by type of object, but we 

can filter the list by clicking the pane’s title bar and then clicking the category or group of 

objects. 

  Status bar: Across the bottom of the program window, this bar displays information about the 

current database and provides access to certain program functions. 

 
 

To open Microsoft Access using the Start program: 

 Click the Start button located in the lower left corner of the Windows screen. 

 Click the Programs option on the Start menu. 

 Click the Microsoft Access selection. 

 
 

Applications of MS ACCESS window 

 Beyond desktop databases

Access is now much more than a way to create desktop databases. It’s an easy-to-use tool for quickly 
creating browser-based database applications that help you run your business. Your data is 



automatically stored in a SQL database, so it’s more secure than ever, and you can easily share your 
applications with colleagues. 

 

 App templates

Easily get started by creating a custom app or get inspired by a collection of new and professionally-
designed app templates. 

 

 Autocomplete control

Entering data is now much easier and less error-prone for app users with drop downs and 
recommendations made upon beginning to type in data. Lookups allow for drawing relationships 
between records in different tables. 

 

 Data stored in SQL

The back end has been moved to SQL Server and Microsoft Azure SQL Database to allow for added 
reliability, robust security, scalability and long-term manageability 

 

LIMITATIONS OF MS ACCESS 
 

  Access has been designed for desktop use, more like a personal database. That means 

Access is more useful for individual departments or small medium business sector 

 Access also has difficulty dealing with databases larger than 2GB in size 

 As you scale up the size, performance becomes sluggish 

 Publishing anything other than static files is a problem with Access. 

 Technical limit is 255 concurrent users, but real world limit is 10 to 80 (depending on type of 

application). 

 All the information from database is saved into one file. This limits options and how you choose 

utilize data; slowing down reports, queries, and forms. Its performance becomes slow as the 

user scales data size. Multimedia data can use up MS Access limited space quickly. 

 the SQL in MS Access is not as robust as other databases 

 
 
 

Database: 
 

A database is a collection of information organized and presented to serve a specific purpose. 

Database programs are created using a program like Microsoft Access.Tables are one of the types of 

database objects to work with in Access. Other types include forms, queries, reports, macros, and 

modules. 



Of these object types, only tables are used to store information. The others are used to enter, manage, 

manipulate, analyze, retrieve, or display the information stored in tables. These components are called 

database objects. 

Table 
 

  Databases store information in the form of tables. These simple databases are often called flat file 

databases, or just flat databases. 

  When we view a blank database for the first time in Datasheet view, we see a column named ID. 

This column is by default the primary key field. 

  A primary key is a field or combination of fields that uniquely identify each record in a table. No 

two records in a table should have the same values in every field. 

 
This list is arranged in a table of columns and rows. 

  Each column represents a field—a specific type of information about an employee: last name, 

first name, hire date, and so on. 

  Each row represents a record—all the information about a specific employee. 

  Datasheet view displays the table’s data in columns (fields) and rows (records). The first row 

contains column headings (field names). 

 

 



10. Click OK. Access names your table. 
 

 

 
Data 
Type 

Meaning 

Text It can store 255 alphanumeric characters 

Number Used for calculations. 

Date/Time Used for storing date or time 

Currency Used for monetary values like amount 

Counter Is a numeric value that is automatically incremented 
with the addition of each record. 

Memo Used for storing detailed descriptions 

Yes/No Used for storing Boolean values 

OLE Used for storing OLE objects or graphics 

 
 

FORMS: 

A form acts as a friendly interface for a table. Through a form, you can display and edit the 

records of the underlying table, or create new records.It is a collection of controls that either accept 

information or display information. You can create forms by using a wizard, or you can create them 

from scratch by manually selecting and placing the controls. Access provides the types of controls 

that are standard in Windows dialog boxes, such as labels, text boxes, option buttons, and check 

boxes. 

We can display forms in several views. The following are the three most common views: 

▪ Form In this view, you can display and enter data. 



▪ Layout In this view, you can work with the elements of the form to refine its appearance and 

functionality while also displaying the data from the underlying table. 

▪ Design In this view, you have more precise control over the appearance, placement, and functionality 

of form elements, but you cannot display the underlying data. 

 

Steps to create a form 

 

 

 
QUERIES: 

The benefit of a database is to select the data in number of ways according to requirement of the user. 

It is possible by specifying the conditions to display the data.   Ms-Access retrieves the data to answer the 

query and user can view and analyze this data to create a form, a report or ever another query. User can design 

a simple query to involve a single table or complex queries to involve any tables. 

we can create queries by using a Query wizard, and you can also create them from scratch. The 

most common type is the select query, which extracts matching records from one or more tables. 

 
Steps to create a Query 

 Open the database containing the table you want to query in Microsoft Access. 



 On the Create tab of the Access ribbon, click the Query Wizard button. 

 Select Simple Query Wizard. 

 Click OK to continue. 

 
REPORTS : 

Reports can display the information recorded in our tables in nicely formatted, easily accessible 

reports, either on your computer screen or on paper. A report can include items of information selected 

from multiple tables and queries, values calculated from information in the database, and formatting 

elements such as headers, footers, titles, and headings. 

We can look at reports in four views: 

▪ Report view: In this view, you can scroll through the information in the report without being distracted 

by the page breaks that will be inserted when it is printed. 

▪ Print Preview: In this view, Access displays your report exactly as it will look when printed. 

▪ Layout view: This view displays the data in the report (similar to Print Preview) but enables you to edit 

the layout. 

▪ Design view: In this view, you can manipulate the design of a report in the same way that you 

manipulate a form. 

 
Steps to create the Report button 

 
 Open the Navigation pane. 

 Click the table or query on which you want to base your report. 

 Activate the Create tab. 

 Click the Report button in the Reports group. Access creates your report and displays your report 

in Layout view. You can modify the report. 

 
The significance of graphs in reports 

A report can integrate a graph using the graph wizard. Graphs can be placed either on 

reports or forms. It is treated as a label or text box. The labels and data points used in graphs are 

based on the fields in the selected tables or queries. The procedure to integrate a graph in a 

report using graph wizard is as follows: 

 Click on Reports Object from Database Window 

 Select the report to place a graph and click DESIGN button. The report is displayed in the Design 

view. 

 Drag the bottom of the report footer bar and make room for the addition of graph at the end of 

the report. 

 Use the Insert/chart menu selection and a chart wizard dialog box is displayed. 

 Pick up the table name and click next to display the chart wizard. 

 Select the required fields for the chart from the list of fields and click next. 

 The chart wizard displays no of different chart types select any one click next. 

 Drag the chart box to make it large enough to display all elements. 



 The label names orientation, fonts, size and char type can be easily modified. Legends are added 

using the Insert / Legends menu. 

 Save report with chart by using File / Save As. 

 Press Ctrl + W to close the window. 

 

MS EXCEL 
 

FEATURES OF MS EXCEL 

 
MS Excel is a Windows-based application package that can be used to automate tasks such as 

calculation and analysis of data, automate financial statements, business forecasting, transaction 

registers, inventory control, etc. It provides multiple facilities, such as making graphs and charts, 

analyzing situations, and helps users at the managerial level in taking decisions. The features 

provided by Excel are very useful for managers as well as the supervisors in any type of 

organization and help them to execute their complex tasks with a minimum effort. It is extensively 

used in financial organizations. The features of MS Excel are as follows: 

1. Functions and formulas: The built-in formulas are called functions. MS Excel provides analyzing 

data and manipulating text by using different functions. Users can easily calculate sum, interest, 

average, etc. by using built-in functions. This can be done either by typing in the function-based 

formulas or by using function wizards. Formulas are widely used in simple computing (such as 

addition, subtraction, multiplication and division) and advanced computing. They provide the power 

to analyze data extensively. 

2. Auto-calculation: MS Excel spreadsheet allows a user to automatically recalculate the whole 

worksheet every time a change is made in a single cell. 

3. Charts & Graphs: One of the most important features of MS Excel is a chart. MS Excel allows users 

to view data entered as tables in a graphical form as charts, which helps a user to easily understand, 

analyze, and compare data. 

4. Entering Data in Series: A user can fill a range of cells either with the same value or with the series 

of values. This can be done using the Autofill handle (small square on the bottom-right corner of the 

active cell). 

5. Sorting: This feature allows the data to be sorted either in ascending or descending order. 

6. Filtering: Using AutoFilter to filter data is a quick and easy way to find and work with a subset of 

data in a range of cells or table column 

7. Pivot Table & Pivot Charts: Use a PivotTable report to summarize, analyze, explore, and present 

summary data. Use a PivotChart report to visualize this summary data in a PivotTable report, and to 

easily see comparisons, patterns, and trends. Both a PivotTable report and a PivotChart report 

enable you to make informed decisions about critical data in your enterprise. 

8. Validation: Prevents invalid data entry in a worksheet. 



The Excel Spreadsheet/Worksheet & Workbook 
 

The spreadsheet is divided into number of columns and rows with labels. The intersection of a 

column and a row is a cell. A cell can be identified by its cell reference composed of the column letter 

followed by the row number e.g. C2. 

 
The active cell is the location in the spreadsheet that is currently selected. It can be identified by 

the black border around it, or by its cell reference in the Name Box. The column and row headers appear 

highlighted when a cell or range is selected to help the user identify the selected area. 

 
There are 256 columns in a spreadsheet 

ranging from A to Z and then AA to AZ, BA to BZ 

and so on. There are 65,536 rows in a spreadsheet. 

 
Workbook: When MS Excel is opened, by default a 

workbook is opened which consists three 

worksheets named sheet1, sheet2, 

sheet3 by default which can be renamed, deleted or a new sheet can be inserted into the workbook. 

b) The Cell, Cell Pointer and Cell Address. 

 
An Excel worksheet is made up of columns and rows. Where these columns and rows intersect, they 

form little boxes called cells. The active cell, or the cell that can be acted upon, reveals a dark border. All 

other cells reveal a light gray border. Each cell has a name. Its name is comprised of two parts: the 

column letter and the row number. 

 
Parts Of MS Excel Window 

 



 

1. Tool Box- this buttons are used to close windows, restore or maximized, and minimized the 

application window. 

 
2. Title Bar- use to notify the filename of your document after saving it and the name of your office 

application. 

 
3. Menu Toolbar- use to select command application using the customized drop/down window in 

various applications, such as the format menu. 

 
4. Formatting Toolbar- use to change the appearance of the text, objects, mathematical application, 

alignment, currency, and decimals, etc. 

 
5. Standard Buttons- compose of the most basic command application, presented by buttons to easily 

familiarize and click by the mouse pointer in single click and using the dialogue box as our 

communication to the application of computer. such as the NEW button for a new worksheet. 

 
6. Name Box- this is situated in the left of the window.We will notice a letter combine with number. The 

Letter signifies the column and the number is row. 

 
7. Editor Bar/Formula bar- This bar is next of the name box. Editor bar called also as the formula bar, 

meaning you can edit or change data and create logical formula using this bar.But you can use actually 

the worksheets as editor by pressing the F2 key of your keyboard. 

 
8. Column Header- they are alphabets situated and underneath of the formula bar.It is represent the 

number of columns in a worksheet. It is composed of 256 columns.we can count number of columns in 

single worksheet by holding CTRL + right arrow key of the keyboard. 

 
9. Row Header- they are numerical numbers, from 1-104856 rows in 2007 version.You can count how 

much the number of rows in a single worksheet by holding CTRL + Down arrow key. 

 
10. Worksheet Cell- It’s just bolded rectangle position normal in A1 once you open your MS- EXCEL.This 

is use to refer the data in your applications.Meaning, once you type your data, the number or text will 

position inside the worksheet cell in the different intersection of the worksheets application. 

 
11. Auto fill Tab- It’s a box situated in the below right portion of the worksheet cell used to perform 

application automatically using the drag of the mouse.Such as to perform logical calculation of the 

single column of the worksheets.Such as calculating or adding the numbers using the logical 

formula.The date, year, month, and the numbers in series. 

 
12. Tab Buttons- This tabulated buttons is used to name the single worksheets in single 

workbook.Normally as default, it has three tab sheets that you can rename and adding it by pointing 

your mouse cursor in a tab sheets and use the right click of your mouse. 



13. Worksheet- it is the wide area of your window application. It is the spreadsheet paper literary.That 

simulated in electronic spreadsheet application.It has composed of vertical and horizontal grid lines to 

form an intersection of the worksheet. 

 
14. Vertical Scroll Bar- it is situated right side of the worksheet.It is used to move up/down of the 

worksheet or page in the application. 

 
15. Horizontal Scroll Bar- it is situated right of the tab sheet button.It is used to move the worksheet or 

page left and right of the application. 

 
16. Zoom In Zoom Out Sliding Bar- it is situated right/down in MS-Excel 2007 application window.It is 

use to increase/decrease the size of the worksheet. 

 
 
 
 
 
 

Saving, Opening and closing workbook 

 
OpenDocument in MS Excel 

 

1. Click the Microsoft Office Button  , and then click Open. 

2. Click the file you want to open, and then click Open. 

 
Saving document in MS Excel file 

 

1. Click the Microsoft Office Button  , and click Save As. 

2. Click OpenDocument Spreadsheet. 

Entering and Editing Data 

 
  To enter data into Excel, click on the cell, type in your data and press Enter. 

  After pressing Enter the cell below the current one then becomes the active cell. Other 

alternatives are: 

Tab key: Enters the data and the cell to the right of the current cell becomes the active cell 

Arrow keys: Enters the data and the cell dependent on the direction of the arrow key pressed 

becomes the active cell 

Mouse click: Enters the data and the cell clicked becomes the active cell 

Esc key: Cancels the entry 



Changing the width of a column 

 
  By default, Excel's columns are 8.43 characters wide, but each individual column can be enlarged 

to 240 characters wide. 

  Select the column/row go to edit menu select height / width and type the specific width & height 

 
Editing a cell 

 
To edit cells content, you need to be in editing mode. To access editing mode, select the cell and press 

F2, double click or edit the cells content directly in the formula bar and press Enter. 

 
INSERTION AND DELETION OF WORKSHEET 

 

Inserting rows on a worksheet 

 
 Select the row, or a cell in the row below where you want the inserted row to appear. For 

example, if you wanted to insert a row between rows 7 and 8, select row 8. 
 Click Insert>Rows Inserting columns on a worksheet 

 Select the column, or a cell in the column to the right of where you want the inserted column to 
appear. For example, if you wanted to insert a column between columns C and D, select column D. 

 Click Insert>Columns Inserting cells on a worksheet 

 Select the cell, or the range of cells where you want to insert the new cells. Select the same 
number of cells as you would like to insert 

 Click Insert>Cells 
 In the dialogue box that appears select the direction in which to shift the surrounding cells 

 
Deleting rows, columns and cells 

 
 Select the rows or columns to be deleted. 
 Click Edit>Delete 
 The rows or columns are deleted and all other rows and columns are shifted up and to the left 

To delete data in a cell 

 
 Select the cell or cells to be deleted. 
 Click Edit > Delete 
 In the dialogue box that appears select the direction in which to shift the surrounding cells 



Note: Pressing the delete key only removes the contents from the cells and will not delete the 

rows, columns or cells. 

Inserting a worksheet 

 
 Select the worksheet after where you would like the new worksheet to appear. The new 

worksheet appears to the left of the currently selected worksheet. 
 Click Insert>Worksheet 
 The new worksheet is named according to the number of worksheets you currently have. For 

example if you have 3 sheets, then the new worksheet is named sheet4 
Deleting a worksheet 

 
 Select the worksheet that you wish to delete 
 Click Edit>Delete 

 
The delete key will only delete the contents of a cell and will not delete worksheets. 

 

AUTO FILL 
 

An amazing and often underutilized feature of Excel is the Auto fill. Auto fill is the use of the fill 

handle to copy data and sequences across a range of cells. 

 
To fill a range of cells: 

 
 Select the cell with the content you wish to copy 
 Point at the black square that appears in the bottom right corner of the cell, until your mouse 

pointer becomes the fill handle 
 Click and drag in the direction of the range you wish to fill. 

 
Excel will copy the contents of the cell across the range that you select. This will also work with dates. 

This feature becomes very powerful when used with cells containing formulas. A lot of time can be 

saved by copying formulas across a range of cells. This is covered in relative and absolute cell references. 

REFERENCES: RELATIVE, ABSOLUTE AND MIXED 

 
When copying cells containing formulas, any cell references will be changed in relation to its new 

position. 

 
For example, the formula =SUM (C4:C7) in cell C9 has been copied along to cells D9:H9. 

 



 

 

As the formula was copied to the right, the cells it referred to, i.e. C4:C7, also moved right becoming 

D4:D7, E4:E7 and so on. This type of reference is known as a relative cell reference because the cells 

moved in relation to our movement. 

 
There are times when you require cells to be fixed. This type of cell reference is known as an absolute 

cell reference. Absolute cell references can be identified by $ symbols within the cell reference e.g. $B$5. 

 
In the example below cell D3 contains the formula =C3*D1. When the formula is copied down to cells 

D4:D7 we do not wish for cell D1 to move. To fix cell D1 we will make it absolute. 

 
There are also mixed references. Mixed references are when only the column or row is fixed. For 

example, $B5 is a mixed reference with the column absolute and the row relative, and B$5 has the 

column relative and the row as an absolute reference. 

 
You can make a mixed reference by either typing the $ sign in the appropriate position or pressing the 

F4 key. The F4 key will toggle between the relative, absolute, mixed row and mixed column options. 

 
 

FUNCTIONS: MEANING AND ADVANTAGES OF FUNCTIONS 

 
Functions 

 
A function is a built in formula. There are over 400 built in functions in Excel that can be 

accessed through the Insert Function button on the Formula Bar. After clicking the Insert 

Function button, the Insert Function dialogue box appears. Type in the name of the function, or select 

the relevant category to find the function you are looking for. A description of the function is displayed 

when a function is selected. Click Ok. 

 
The Function Arguments dialogue box appears. Arguments are the information that the function 

needs in order to do its job.The image below shows the arguments required for the IF() 



function. The argument in bold is mandatory, while the others are optional. When an arguments field 

is selected a description of what is required appears below 

 
A function is made up of four parts: 

 
Equals sign = 

Function name i.e. SUM 

Parentheses Arguments (each argument is separated by a comma) 

 

 
 

 
DIFFERENT TYPES OF FUNCTIONS AVAILABLE IN EXCEL 

 
There are number of functions in Excel. They are 

 
 Date and Time Functions 

 Statistical Functions 

 Mathematical Functions 

 Financial Text Functions 

 Logical Functions. 

 

 
DATE AND TIME FUNCTIONS 

 
TODAY( ): This function returns the current date. 

 
NOW( ): This function returns both the current date and time. 

 
DATE( ):If u want a specific date in a cell in the format of year, month , day it gives the output as 

o5/09/2007 



DAY( ): It gives the day of a month from the given data. If we take the format 05/09/2007, this function 

returns 5 as the date. 

 

MONTH( ): It gives the month of a given data. In the above example 05/09/2007, this function returns 9 

as the month. 

 

 
YEAR( ): This function returns 2007 as the result for the above example date. 

 

STATISTICAL FUNCTIONS 
 

There are a number of statistical functions in Excel which can be used to analyse the data in your 

spreadsheet. These include, but are not limited to Count, Average, Min and Max. 

 

COUNT( ): Returns the number of values from a list. 
 

AVERAGE( ):Returns the average or arithmetic mean of a list of values. 
 

MIN( ): Returns the smallest number from a list of values. 
 

MAX( ): Returns the largest number from a list of values. 

 

MATHEMATICAL FUNCTIONS 
 

ABS( ): Returns the absolute value of a number. The absolute value of a number is the number without 

its sign. 

EXP( ): Returns e raised to the power of number. 
 

INT ( ): Rounds a number down to the nearest integer. 
 

MOD( ): Returns the remainder after number is divided by divisor. The result has the same sign as 

divisor. 

LOG( ): Returns the logarithm of a number to the base you specify. 
 

ROUND( ): Rounds a number to a specified number of digits. 
 

SQRT( ): Returns a positive square root. 

 

 
LOGICAL FUNCTIONS 

 

Returns TRUE if all its arguments are TRUE; returns FALSE if one or more argument is FALSE. 



AND(logical1,logical2, ...) 
 

IF(logical_test,value_if_true,value_if_false) 
 

Logical_test is any value or expression that can be evaluated to TRUE or FALSE. Create a blank 

workbook or worksheet. 

 

 

 Selecting an example from Help 

 Press CTRL+C. 

 In the worksheet, select cell A1, and press CTRL+V. 

 
To switch between viewing the results and viewing the formulas that return the results, press 

CTRL+` (grave accent), or on the Formulas tab, in the Formula Auditing group, click the Show Formulas 

button. 

 

 
GRAPHS AND CHARTS 

 
You can create many different types of chart in Excel to create the ideal visual representation of your 

data. The most common chart types in Excel include: 

 
 Column chart - used to compare different values side by side. Each value is represented by a 

column. Multiple data series are identified by different coloured columns. 
 Line chart - used to illustrate trends over time. Each value is plotted as a point and connected by 

a line through each point. 
 Pie chart - used for showing values as a percentage of a whole. Each value is represented by a 

different coloured segment of the pie. 
 Bar chart - like column charts but are displayed horizontally. Also used to compare vales side 

by side. 
 Area chart - like line charts except that the area beneath the line connecting the points is filled 

by a colour. 
 Scatter chart - used to plot a cluster of values. Multiple items can be plotted by using 

different coloured points. 
 

1. FILTERING Autofilter 



You can filter data to only display the rows that you want to see. All other data is hidden. You 
can also filter by multiple columns reducing your data each time to what you want. 

 
Apply a filter 

 
1. Select a cell in the range that you wish to filter 

2. Click Data&Filter and then AutoFilter from the submenu that appears 

 
Filter buttons appear in the first cell of each column (these should be your headers) 

3. Click the filter button for the column you want to filter 

4. Select a value from the list that appears 

 
 
 

Removing the filter 

 
5. Click Data>Filter 

6. Select AutoFilter from the submenu 

7. The filter buttons disappear and any filters you may still have applied are removed 

 

Custom AutoFilter 

Custom AutoFilter enables you to use your own criteria to filter your data. For example, the orders 

after a specific date, or the orders less than a specific order total. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Questions: 

Unit -1 :  

Short Answer Questions: 

1. Define computer. Explain block diagram of computer. 

2. Applications of computer. 

3. Types of Printers. 

4. Types of Plotters. 

Long Answer Questions: 

1. Define Computer. Explain characteristics of Computer. 

2. Explain the classification of Computers with a suitable chart. 

3. Explain the various Input output devices of the computer. 

4. Define computer. Explain the generations of computer. 

Unit – 2: 

Short Answer Questions: 

1. RAM and types of RAM. 

2. ROM and types of ROM. 

3. Magnetic tape and magnetic disk 

Long Answer Questions: 

1. Define Number System and Explain different types of number system with the relevant example. 

2. What is computer memory? Explain the primary memory storage and secondary memory storage. 

Unit – 3: 

Short Answer Questions: 

1. Word Processing 

2. High level languages. 

3. Low level languages 

Long Answer Questions: 

1. What is a programming language. Discuss their relevance in computer science. 

2. What is a software? Explain the various types of computer software. 

3. What are the features of Spreadsheet? 

 



4. What is DBMS? Explain features of DBMS. 

Unit – 4: 

Short Answer Questions: 

1. What is Linux? 

2. Differentiate between compiler and interpreter. 

3. Batch processing operating system. 

Long Answer Questions: 

1. What is an operating system? Explain the various types of operating systems. 

2. What is DOS? Explain features of DOS. 

3. What is Windows? Explain features of Windows. 
 

Unit – 5: 

Short Answer Questions: 

1. What is internet? Explain the various types of service and components used in internet. 

2. Types of network ( LAN, MAN, WAN ) 

3. Modem 

Long Answer Questions: 

1. What is Computer Network? Explain various computer networks along with advantages and 
disadvantages. 

2. What is data communication? Explain the basic elements of data communication. 

3. What is network topology? Discuss the various topologies with their advantages and 
disadvantages. 

  


